summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-08-19 20:48:51 +0000
committerMatthias Clasen <mclasen@redhat.com>2020-08-19 20:48:51 +0000
commitf26b61331403a337a4753b512df25f154891c237 (patch)
tree581421a87ee3bb20e534ef8ffdabed8ce0414f11 /meson.build
parent1f8e988bd580627b6310f6ff01e0b4947b739996 (diff)
parent13f8625431eba74e070e846b23fcfc2a0ff2b34d (diff)
downloadpango-f26b61331403a337a4753b512df25f154891c237.tar.gz
Merge branch 'sysprof-tracing' into 'master'
Add sysprof tracing support See merge request GNOME/pango!227
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 288405cf..00b9df91 100644
--- a/meson.build
+++ b/meson.build
@@ -538,6 +538,23 @@ if cairo_dep.found()
endif
endif
+# libsysprof-capture support
+libsysprof_capture_dep = dependency('sysprof-capture-4',
+ required: get_option('sysprof'),
+ default_options: [
+ 'enable_examples=false',
+ 'enable_gtk=false',
+ 'enable_tests=false',
+ 'enable_tools=false',
+ 'libsysprof=false',
+ 'with_sysprofd=none',
+ 'help=false',
+ ],
+ fallback: ['sysprof', 'libsysprof_capture_dep'],
+)
+pango_conf.set('HAVE_SYSPROF', libsysprof_capture_dep.found())
+pango_deps += libsysprof_capture_dep
+
gnome = import('gnome')
pkgconfig = import('pkgconfig')