summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-08-30 16:11:00 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-08-30 16:16:03 +0100
commit98be56d131dc7aa2cb95cbe1d4ea646cb6e924b8 (patch)
tree6eec81c6d447107ba1063d74d1d5e102d1f4e29e /meson.build
parentb6d1048a2631cd4703b43550da5228b724858ee4 (diff)
downloadpango-98be56d131dc7aa2cb95cbe1d4ea646cb6e924b8.tar.gz
build: Add variable for the Pango versioned space
We have the API version and we build the inclusion path from it, but we should have a variable with the versioned namespace ('pango' + API version) and build paths using join_paths() instead. We're also going to use the versioned namespace elsewhere soon.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f6539a4c..f32400f0 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,8 @@ pango_interface_age = pango_minor_version.is_odd() ? 0 : pango_micro_version
pango_binary_age = pango_minor_version * 100 + pango_micro_version
pango_api_version = '@0@.0'.format(pango_major_version)
-pango_api_path = 'pango-@0@/pango'.format(pango_api_version)
+pango_api_name = 'pango-@0@'.format(pango_api_version)
+pango_api_path = join_paths(pango_api_name, 'pango')
pango_conf = configuration_data()