summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTom Schoonjans <Tom.Schoonjans@diamond.ac.uk>2019-07-27 17:43:57 +0100
committerTom Schoonjans <Tom.Schoonjans@diamond.ac.uk>2019-07-27 17:44:01 +0100
commit2eaa4feab269436b3dadc6b058236c19086960e0 (patch)
tree0ae5d3ea5e6da949d0626acb8e2d5c7b49e0a131 /meson.build
parentef6cd3523172603cce446967f14d60ca90b60f21 (diff)
downloadpango-2eaa4feab269436b3dadc6b058236c19086960e0.tar.gz
meson: fix darwin_versions
The darwin_versions argument should take into account the interface_age
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8c41381c..8680e56f 100644
--- a/meson.build
+++ b/meson.build
@@ -42,7 +42,8 @@ pango_conf.set('PANGO_VERSION_MICRO', pango_micro_version)
# Maintain version scheme with libtool
pango_soversion = 0
pango_libversion = '@0@.@1@.@2@'.format(pango_soversion, (pango_binary_age - pango_interface_age), pango_interface_age)
-pango_osxversion = pango_binary_age + 1
+osx_current = pango_binary_age - pango_interface_age + 1
+pango_osxversion = [osx_current, '@0@.@1@.0'.format(osx_current, pango_interface_age)]
cc = meson.get_compiler('c')
host_system = host_machine.system()