summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJehan <jehan@girinstud.io>2019-01-26 14:16:46 +0100
committerJehan <jehan@girinstud.io>2019-01-26 14:38:42 +0100
commit39edaf261b17d5c4bea7a02750c3f5f4e1545d06 (patch)
tree2dd5e4a4f6d4eae7a5475e79b09e0174ad9ed5bd /meson.build
parent982445fe1c234b1ef5173556a73f659946c1a288 (diff)
downloadpango-39edaf261b17d5c4bea7a02750c3f5f4e1545d06.tar.gz
meson: do not set -Werror=redundant-decls for gcc on Windows target.
When cross-compiling with MinGW64, system headers have various redundant declarations. This commit makes pango cross-buildable with MinGW64 while not removing the warning-errors for other OSes.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 76df11b1..25febacb 100644
--- a/meson.build
+++ b/meson.build
@@ -83,7 +83,6 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
'-Wlogical-op',
'-Wno-uninitialized',
'-Wno-shadow',
- '-Werror=redundant-decls',
'-Werror=implicit',
'-Werror=nonnull',
'-Werror=init-self',
@@ -104,6 +103,8 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
if host_system == 'windows'
test_cflags += [ '-mms-bitfields' ]
+ else
+ test_cflags += [ '-Werror=redundant-decls' ]
endif
else
test_cflags = []