summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2019-07-09 21:51:07 -0400
committerMatthias Clasen <mclasen@redhat.com>2019-07-09 22:37:37 -0400
commitf972ba0562823a8d55ad02ff9609481a884c79f8 (patch)
tree3f9950ecd7b1cf5642d77b763dec36b98f7c65e3 /meson.build
parent37fd3ce13b643d1743ae8b69c453a2cfcb0e3eb0 (diff)
downloadpango-f972ba0562823a8d55ad02ff9609481a884c79f8.tar.gz
Reduce overlinking
Only link libpangoxft and libpangocairo against xft and cairo.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 73b5da2b..d1150907 100644
--- a/meson.build
+++ b/meson.build
@@ -183,6 +183,8 @@ endif
# Dependencies
pango_deps = []
+pangoxft_deps = []
+pangocairo_deps = []
glib_req_version = '>= 2.59.2'
fribidi_req_version = '>= 0.19.7'
@@ -314,8 +316,8 @@ endif
xft_dep = dependency('xft', version: xft_req_version, required: false)
if xft_dep.found() and fontconfig_dep.found() and freetype_dep.found()
pango_conf.set('HAVE_XFT', 1)
- pango_deps += dependency('xrender', required: false)
- pango_deps += xft_dep
+ pangoxft_deps += dependency('xrender', required: false)
+ pangoxft_deps += xft_dep
endif
if host_system == 'darwin'
@@ -488,7 +490,7 @@ endif
if cairo_dep.found()
pango_conf.set('HAVE_CAIRO', 1)
- pango_deps += cairo_dep
+ pangocairo_deps += cairo_dep
pangocairo_requires = ''