summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-08-19 16:02:10 -0400
committerMatthias Clasen <mclasen@redhat.com>2020-08-19 16:42:24 -0400
commit13f8625431eba74e070e846b23fcfc2a0ff2b34d (patch)
treead63768096e1e011278bdc1b3c34a6b73c5c7d2b /meson.build
parente08269b8847d64843498f7ebf5bc6e5de6fbc45e (diff)
downloadpango-13f8625431eba74e070e846b23fcfc2a0ff2b34d.tar.gz
Add sysprof tracing support
Add support for adding sysprof marks. Strongly inspired by equivalent GLib support.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 288405cf..00b9df91 100644
--- a/meson.build
+++ b/meson.build
@@ -538,6 +538,23 @@ if cairo_dep.found()
endif
endif
+# libsysprof-capture support
+libsysprof_capture_dep = dependency('sysprof-capture-4',
+ required: get_option('sysprof'),
+ default_options: [
+ 'enable_examples=false',
+ 'enable_gtk=false',
+ 'enable_tests=false',
+ 'enable_tools=false',
+ 'libsysprof=false',
+ 'with_sysprofd=none',
+ 'help=false',
+ ],
+ fallback: ['sysprof', 'libsysprof_capture_dep'],
+)
+pango_conf.set('HAVE_SYSPROF', libsysprof_capture_dep.found())
+pango_deps += libsysprof_capture_dep
+
gnome = import('gnome')
pkgconfig = import('pkgconfig')