summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-11 21:44:56 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-11-18 13:58:15 -0500
commit2aead7a8e8828de6afef96611661997a52ca6739 (patch)
treedc1c796d9c95f7784648eddcc08b26bc39a762e1 /meson.build
parent2f2cb72672c7f74e2648594819b7cde95ca0ed1d (diff)
downloadpango-2aead7a8e8828de6afef96611661997a52ca6739.tar.gz
Add layout serialization api
Add api to serialize PangoLayout, for the benefit of testing and debugging. Currently, this uses json, but that is an implementation detail. Some tests included.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 37bcf6cb..4acb0654 100644
--- a/meson.build
+++ b/meson.build
@@ -232,6 +232,7 @@ harfbuzz_req_version = '>= 2.6.0'
fontconfig_req_version = '>= 2.13.0'
xft_req_version = '>= 2.0.0'
cairo_req_version = '>= 1.12.10'
+json_glib_version = '>= 1.6.0'
# libm
mathlib_dep = cc.find_library('m', required: false)
@@ -251,6 +252,9 @@ fribidi_dep = dependency('fribidi', version: fribidi_req_version,
default_options: ['docs=false'])
pango_deps += fribidi_dep
+json_glib_dep = dependency('json-glib-1.0', version: json_glib_version)
+pango_deps += json_glib_dep
+
thai_dep = dependency('libthai', version: libthai_req_version, required: get_option('libthai'))
if thai_dep.found()
pango_conf.set('HAVE_LIBTHAI', 1)