summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-29 23:53:12 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-12-02 17:57:42 -0500
commit53d9610af5ce0861fba3c2c29bda9367a8bcca61 (patch)
tree8366b6d74bd20d575e804e529df65ceb6a851147 /meson.build
parentf15cf8af0b14c6a4c60ce6de8a73f2fe6ac63541 (diff)
downloadpango-53d9610af5ce0861fba3c2c29bda9367a8bcca61.tar.gz
serializer: Replace json-glib
Replace json-glib by a homegrown json parser/printer.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index c91ddb52..7afe6193 100644
--- a/meson.build
+++ b/meson.build
@@ -232,7 +232,6 @@ harfbuzz_req_version = '>= 2.6.0'
fontconfig_req_version = '>= 2.13.0'
xft_req_version = '>= 2.0.0'
cairo_req_version = '>= 1.12.10'
-json_glib_version = '>= 1.6.0'
# libm
mathlib_dep = cc.find_library('m', required: false)
@@ -252,10 +251,6 @@ fribidi_dep = dependency('fribidi', version: fribidi_req_version,
default_options: ['docs=false'])
pango_deps += fribidi_dep
-json_glib_dep = dependency('json-glib-1.0', version: json_glib_version,
- fallback: ['json-glib', 'json_glib_dep'])
-pango_deps += json_glib_dep
-
thai_dep = dependency('libthai', version: libthai_req_version, required: get_option('libthai'))
if thai_dep.found()
pango_conf.set('HAVE_LIBTHAI', 1)