summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-02-10 16:49:26 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-03-11 13:17:36 -0500
commit99b0d11c78c9fde7f5facbdf16ea5c6ab1e48e16 (patch)
treec407a1588737aa30390bde9273236275b115c765 /meson.build
parentb14514d8afb1c50a863beef5a43b360e47c0442f (diff)
downloadpango-99b0d11c78c9fde7f5facbdf16ea5c6ab1e48e16.tar.gz
Generate Pango API docs with gi-docgen
Stop using gtk-doc, and switch to gi-docgen. The gi-docgen tool generates API references through the introspection data, which has various benefits: - it does not parse C code - it does not generate and run C code to introspect types at build time - it does not present a different API from the one we're exporting Additionally, gi-docgen: - does not generate DocBook XML in order to generate HTML - does not go through xsltproc - parses proper Markdown Which makes it markedly faster than gtk-doc has ever been.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 28d9c9ba..f9e63347 100644
--- a/meson.build
+++ b/meson.build
@@ -585,6 +585,10 @@ libsysprof_capture_dep = dependency('sysprof-capture-4',
pango_conf.set('HAVE_SYSPROF', libsysprof_capture_dep.found())
pango_deps += libsysprof_capture_dep
+gidocgen_dep = dependency('gi-docgen', version: '>= 2021.1',
+ fallback: ['gi-docgen', 'dummy_dep'],
+ required: get_option('gtk_doc'))
+
gnome = import('gnome')
pkgconfig = import('pkgconfig')