summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-10-12 21:14:23 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-10-12 21:20:31 +0530
commitef55e1928dabca0192218a03467fe975ed51963d (patch)
treedaafd995bcc1b526ffba45f8910c5dd6ebb94c18 /meson.build
parentad26d15133c88394362acb797ce072302051a899 (diff)
downloadpango-ef55e1928dabca0192218a03467fe975ed51963d.tar.gz
meson: Set the compatibility version correctly on macOS
Requires the latest Meson. Closes https://gitlab.gnome.org/GNOME/pango/issues/320
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index aad51b4d..48c2981b 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('pango', 'c', 'cpp',
'warning_level=1',
'c_std=c99',
],
- meson_version : '>= 0.47.0')
+ meson_version : '>= 0.48.0')
add_project_arguments([ '-D_POSIX_C_SOURCE=200809L', '-D_POSIX_THREAD_SAFE_FUNCTIONS', '-D_GNU_SOURCE', ], language: 'c')
@@ -40,6 +40,7 @@ pango_conf.set('PANGO_VERSION_MICRO', pango_micro_version)
# Maintain version scheme with libtool
pango_soversion = 0
pango_libversion = '@0@.@1@.@2@'.format(pango_soversion, (pango_binary_age - pango_interface_age), pango_interface_age)
+pango_osxversion = pango_binary_age + 1
cc = meson.get_compiler('c')
host_system = host_machine.system()
@@ -138,11 +139,6 @@ if host_machine.system() == 'linux'
common_ldflags += cc.get_supported_link_arguments([ '-Wl,-Bsymbolic', '-Wl,-z,relro', '-Wl,-z,now', ])
endif
-# Maintain compatibility with autotools on macOS
-if host_machine.system() == 'darwin'
- common_ldflags += [ '-compatibility_version 1', '-current_version 1.0', ]
-endif
-
# Functions
checked_funcs = [
'sysconf',