summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-16 10:10:23 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-16 10:10:23 +0000
commit6cc141fdd95ba7b2623f176e7a4321524d600641 (patch)
treeb8acaef91f4886ca12bc8fffbf12f9a600fa878e /modules/Makefile.am
parent240877fc00047a2898f8f8d338684c2e4e087b90 (diff)
downloadpango-6cc141fdd95ba7b2623f176e7a4321524d600641.tar.gz
Fixes bug #71414, allowing to disable building/installing modules.
2006-01-16 Behdad Esfahbod <behdad@gnome.org> Fixes bug #71414, allowing to disable building/installing modules. * configure.in: Add support for --with-dynamic-modules. * */Makefile.am: Adapt to the above change.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 39cc6ff7..73b2cf43 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -42,5 +42,10 @@ included-modules:
( cd $$d && $(MAKE) $(AM_MAKEFLAGS) included-modules ) ; \
done
-.PHONY: included-modules
+dynamic-modules:
+ @for d in $(SUBDIRS) ; do \
+ ( cd $$d && $(MAKE) $(AM_MAKEFLAGS) dynamic-modules ) ; \
+ done
+
+.PHONY: included-modules dynamic-modules