summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorElliot Lee <sopwith@redhat.com>2000-06-19 17:15:45 +0000
committerElliot Lee <sopwith@src.gnome.org>2000-06-19 17:15:45 +0000
commite2dc9e117648e267953d7318bd3e0093cd5ab234 (patch)
tree4a582a231b2efca221ec86cf80e12dc7451e99d3 /modules/Makefile.am
parentb9aaea84c9092c83906676aa97d8a7ea89a51f36 (diff)
downloadpango-e2dc9e117648e267953d7318bd3e0093cd5ab234.tar.gz
g_strcasecmp returns 0 when strings are equal - negate return value.
2000-06-11 Elliot Lee <sopwith@redhat.com> * pango/fonts.c (pango_font_description_compare): g_strcasecmp returns 0 when strings are equal - negate return value. 2000-06-09 Elliot Lee <sopwith@redhat.com> * pango/pango-coverage.[ch]: Return 'coverage' from pango_coverage_ref. 2000-06-08 Elliot Lee <sopwith@redhat.com> * pango/Makefile.am: Add DOTMODULESDIR define to make it easier to change location of .modules files. * pango/modules.c: Make use of aforesaid define. Also scan the DOTMODULESDIR directory for multiple config files instead of just pango.modules. Also fclose() opened files.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index e2ba627f..0e7737cc 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -8,7 +8,9 @@ SUBDIRS = \
tamil \
thai
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/pango
- $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.so > $(DESTDIR)$(localstatedir)/lib/pango/pango.modules
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pango
+ $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.so \
+ > $(DESTDIR)$(sysconfdir)/pango/pango.modules