summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2001-01-04 17:47:39 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-01-04 17:47:39 +0000
commit4c94c88fb0c4f92c5dbbcd7c07140e0807351353 (patch)
treee3266d1b35423087f6a30811c725fddb3b62abfc /modules/Makefile.am
parent6462b4e6f2389cc000801282da1e3cefefd83ca3 (diff)
downloadpango-4c94c88fb0c4f92c5dbbcd7c07140e0807351353.tar.gz
put creation of module file here. Fixes problem if you 'make install' with
2001-01-04 Havoc Pennington <hp@redhat.com> * pango/Makefile.am (install-data-local): put creation of module file here. Fixes problem if you 'make install' with no preceding 'make' reported by Michael Meeks. * modules/Makefile.am (install-data-local): remove creation of module file from here * Makefile.am (SUBDIRS): remove pango-config * configure.in: use pkg-config to detect GLib cflags/libs * pangoxft.pc (Description): fix name/description
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index b031ac88..3e71db7e 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -8,18 +8,5 @@ SUBDIRS = \
tamil \
thai
-
-
-install-data-local:
- ($(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pango; \
- if ls $(DESTDIR)$(libdir)/pango/modules/*.so | grep -q 'so'; then \
- echo "Wrote $(DESTDIR)$(sysconfdir)/pango/pango.modules."; \
- $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.so \
- > $(DESTDIR)$(sysconfdir)/pango/pango.modules; \
- else \
- echo "No dynamic modules were installed; all modules were linked statically."; \
- echo "# This is an empty file, because Pango was installed with no dynamic modules" > $(DESTDIR)$(sysconfdir)/pango/pango.modules; \
- fi)
-
EXTRA_DIST = \
module.def