summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-06 17:05:17 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-06 17:05:17 +0000
commit21e3135bf7cd6038894c31a42d217504aab9a192 (patch)
tree77e02414848b6cea8a6d1b7b51f3bfca73a9763f /modules/Makefile.am
parent59f899b57621dc1c172c39ef990bc16ec2ef77d6 (diff)
downloadpango-21e3135bf7cd6038894c31a42d217504aab9a192.tar.gz
Fix problem where == was used instead if =. (#73694, Martin Gansser)
Wed Mar 6 11:43:46 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Fix problem where == was used instead if =. (#73694, Martin Gansser) * modules/Makefile.am (install-data-local): Simplify the rule to create the pango.modules file to avoid problems with differing shared library suffixes. pango-querymodules run without any arguments does the right thing by default. (#73694, Martin Gansser) * configure.in: Add a PANGO_MODULE_VERSION variable defining the subdir in which modules are installed. * pango/querymodules.c pango/modules.c modules/*/*.am: Install modules in lib/pango/MODULE_VERSION/modules * pango.pc.in (pango_module_version): Export pango_module_version variable so that 3rd parties can determine where to install libraries.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am18
1 files changed, 3 insertions, 15 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 6bd8f4e9..ea29cb97 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -1,11 +1,5 @@
## Process this file with automake to create Makefile.in.
-if PLATFORM_WIN32
-SOSUFFIX=dll
-else
-SOSUFFIX=so
-endif
-
SUBDIRS = \
arabic \
basic \
@@ -19,15 +13,9 @@ EXTRA_DIST = \
module.def
install-data-local:
- ($(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pango; \
- if ls $(DESTDIR)$(libdir)/pango/modules/*.$(SOSUFFIX) | grep '$(SOSUFFIX)' > /dev/null ; then \
- echo "Wrote $(DESTDIR)$(sysconfdir)/pango/pango.modules."; \
- $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.$(SOSUFFIX) \
- > $(DESTDIR)$(sysconfdir)/pango/pango.modules; \
- else \
- echo "No dynamic modules were installed; all modules were linked statically."; \
- echo "# This is an empty file, because Pango was installed with no dynamic modules" > $(DESTDIR)$(sysconfdir)/pango/pango.modules; \
- fi)
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pango && \
+ $(top_builddir)/pango/pango-querymodules \
+ > $(DESTDIR)$(sysconfdir)/pango/pango.modules
included-modules:
@for d in $(SUBDIRS) ; do \