summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-10-28 22:54:14 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-10-28 22:54:14 +0000
commit53570e37a04c11518dc99c1b6357cff8182c1980 (patch)
tree6f8a9b437da29b7f2c951e812fba5fc9b4707b51 /modules/Makefile.am
parentf5527477d469cf50063bad41de22138806748520 (diff)
downloadpango-53570e37a04c11518dc99c1b6357cff8182c1980.tar.gz
New file, used to build distribution package for Windows.
2001-10-29 Tor Lillqvist <tml@iki.fi> * pango-zip.sh.in: New file, used to build distribution package for Windows. * Makefile.am (EXTRA_DIST): Add pango-zip.sh. * configure.in: Check for lib.exe, set MS_LIB_AVAILABLE. Generate pango-zip.sh. * README.win32: Mention the ways to build Pango on Windows. * modules/Makefile.am * examples/Makefile.am: Se SOSUFFIX to so on Unix, dll on Windows. * pango/Makefile.am: Add rules to create MSVC import library if MS_LIB_AVAILABLE. Add rules to install and uninstall mingw and MSVC import libraries. * tests/Makefile.am: Link with libpangox.la only on Unix.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 4f7f259d..6bd8f4e9 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -1,5 +1,11 @@
## Process this file with automake to create Makefile.in.
+if PLATFORM_WIN32
+SOSUFFIX=dll
+else
+SOSUFFIX=so
+endif
+
SUBDIRS = \
arabic \
basic \
@@ -14,9 +20,9 @@ EXTRA_DIST = \
install-data-local:
($(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pango; \
- if ls $(DESTDIR)$(libdir)/pango/modules/*.so | grep 'so' > /dev/null ; then \
+ if ls $(DESTDIR)$(libdir)/pango/modules/*.$(SOSUFFIX) | grep '$(SOSUFFIX)' > /dev/null ; then \
echo "Wrote $(DESTDIR)$(sysconfdir)/pango/pango.modules."; \
- $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.so \
+ $(top_builddir)/pango/pango-querymodules $(DESTDIR)$(libdir)/pango/modules/*.$(SOSUFFIX) \
> $(DESTDIR)$(sysconfdir)/pango/pango.modules; \
else \
echo "No dynamic modules were installed; all modules were linked statically."; \