summaryrefslogtreecommitdiff
path: root/modules/arabic/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2001-01-03 17:54:42 +0000
committerAlexander Larsson <alexl@src.gnome.org>2001-01-03 17:54:42 +0000
commitbaa65c923254e7e1b8b620f46adaff3447f4625f (patch)
tree4d6001dbe2dd98e75c62cc7f1b85df6a09863183 /modules/arabic/Makefile.am
parentdaa9bd06394d42f4f5840660fab449cbd879554e (diff)
downloadpango-baa65c923254e7e1b8b620f46adaff3447f4625f.tar.gz
Rename all x modules from abc to abc-x.
2001-01-03 Alexander Larsson <alexl@redhat.com> * configure.in: * modules/arabic/Makefile.am: * modules/arabic/arabic-x.c: * modules/basic/Makefile.am: * modules/basic/basic-x.c: * modules/hangul/Makefile.am: * modules/hangul/hangul-x.c: * modules/indic/Makefile.am: * modules/indic/bengali-x.c: * modules/indic/devanagari-x.c: * modules/indic/gujarati-x.c: * modules/indic/gurmukhi-x.c: * modules/indic/myanmar-x.c: * modules/tamil/Makefile.am: * modules/tamil/tamil-x.c: * modules/thai/Makefile.am: * modules/thai/thai-x.c: Rename all x modules from abc to abc-x. * modules/arabic/arabic.c: * modules/basic/basic.c: * modules/hangul/hangul.c: * modules/indic/bengali.c: * modules/indic/devanagari.c: * modules/indic/gujarati.c: * modules/indic/gurmukhi.c: * modules/indic/myanmar.c: * modules/tamil/tamil.c: * modules/thai/thai.c: These were all copied to file-x.c and then removed.
Diffstat (limited to 'modules/arabic/Makefile.am')
-rw-r--r--modules/arabic/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/modules/arabic/Makefile.am b/modules/arabic/Makefile.am
index e12664c5..c456342d 100644
--- a/modules/arabic/Makefile.am
+++ b/modules/arabic/Makefile.am
@@ -15,8 +15,8 @@ XFT_INCLUDED=
XFT_PREFIX=
endif
-sources = \
- arabic.c \
+x_sources = \
+ arabic-x.c \
arconv.c \
mulefont.c \
mulefont.h \
@@ -31,12 +31,12 @@ xft_sources = \
arabic-ot.c \
arabic-ot.h
-if INCLUDE_ARABIC
+if INCLUDE_ARABIC_X
X_MODULES=
-X_INCLUDED=libpango-arabic.la
-X_PREFIX=-DMODULE_PREFIX
+X_INCLUDED=libpango-arabic-x.la
+X_PREFIX=-DX_MODULE_PREFIX
else
-X_MODULES=pango-arabic.la
+X_MODULES=pango-arabic-x.la
X_INCLUDED=
X_PREFIX=
endif
@@ -50,13 +50,15 @@ moduleflags=-rpath $(libdir)
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/pango/ $(moddefine) $(X_CFLAGS) $(FREETYPE_CFLAGS)
-pango_arabic_la_LDFLAGS = $(moduleflags) -export-dynamic -avoid-version -module
-pango_arabic_la_SOURCES = $(sources)
+pango_arabic_x_la_LDFLAGS = $(moduleflags) -export-dynamic -avoid-version -module
+pango_arabic_x_la_SOURCES = $(x_sources)
-libpango_arabic_la_SOURCES = $(sources)
+libpango_arabic_x_la_SOURCES = $(x_sources)
pango_arabic_xft_la_LDFLAGS = -rpath $(libdir) -export-dynamic -avoid-version -module
pango_arabic_xft_la_LIBADD =
pango_arabic_xft_la_SOURCES = $(xft_sources)
libpango_arabic_xft_la_SOURCES = $(xft_sources)
+
+