summaryrefslogtreecommitdiff
path: root/modules/basic/Makefile.am
diff options
context:
space:
mode:
authorKristian Rietveld <kris@gtk.org>2010-03-05 21:46:38 +0100
committerKristian Rietveld <kris@gtk.org>2011-03-27 17:26:44 +0200
commit6c0153b9d360313de9ce70e67ec16f961dc11be2 (patch)
tree2c5c80eec83d93c90ef3dcf72a74cf355229869b /modules/basic/Makefile.am
parent6b522430ad65fe047b077f9cc3990a97e8869e23 (diff)
downloadpango-6c0153b9d360313de9ce70e67ec16f961dc11be2.tar.gz
Start implementation of CoreText backend
On Mac OS X systems where CoreText is available (that is, 10.5 or higher), we will build the CoreText backend instead of the ATSUI backend. In this case, the ATSUI backend will not be built and installed. This change is necessary because since Mac OS 10.5 ATSUI has been marked as deprecated. For older systems, we will have to continue to use the ATSUI backend.
Diffstat (limited to 'modules/basic/Makefile.am')
-rw-r--r--modules/basic/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/basic/Makefile.am b/modules/basic/Makefile.am
index 93604c9e..a264d704 100644
--- a/modules/basic/Makefile.am
+++ b/modules/basic/Makefile.am
@@ -54,6 +54,16 @@ libpango_basic_win32_la_SOURCES = basic-win32.c
libpango_basic_win32_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_basic_win32
if HAVE_CAIRO_ATSUI
+if HAVE_CORE_TEXT
+INCLUDES += $(CAIRO_CFLAGS)
+if INCLUDE_BASIC_CORE_TEXT
+noinst_LTLIBRARIES += libpango-basic-coretext.la
+else
+if DYNAMIC_BASIC_CORE_TEXT
+module_LTLIBRARIES += pango-basic-coretext.la
+endif
+endif
+else
INCLUDES += $(ATSUI_CFLAGS) $(CAIRO_CFLAGS)
if INCLUDE_BASIC_ATSUI
noinst_LTLIBRARIES += libpango-basic-atsui.la
@@ -63,6 +73,13 @@ module_LTLIBRARIES += pango-basic-atsui.la
endif
endif
endif
+endif
+
+pango_basic_coretext_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS) -framework Carbon
+pango_basic_coretext_la_LIBADD = $(pangocoretextlibs)
+pango_basic_coretext_la_SOURCES = basic-coretext.c
+libpango_basic_coretext_la_SOURCES = basic-coretext.c
+libpango_basic_coretext_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_basic_coretext
pango_basic_atsui_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS) -framework Carbon
pango_basic_atsui_la_LIBADD = $(pangoatsuilibs)