summaryrefslogtreecommitdiff
path: root/modules/hebrew/Makefile.am
diff options
context:
space:
mode:
authorChookij Vanatham <chookij@src.gnome.org>2001-04-20 04:01:43 +0000
committerChookij Vanatham <chookij@src.gnome.org>2001-04-20 04:01:43 +0000
commite311e94a1c67ba442d29073aa2f076d151a05e54 (patch)
tree2a4e3076c4f0059743e664069a8b2b6a5ea3f4b8 /modules/hebrew/Makefile.am
parenta1a5c040896150d7e41bf702a6bacecce6fc2461 (diff)
downloadpango-e311e94a1c67ba442d29073aa2f076d151a05e54.tar.gz
Pango X Hebrew Engine.
Diffstat (limited to 'modules/hebrew/Makefile.am')
-rw-r--r--modules/hebrew/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/hebrew/Makefile.am b/modules/hebrew/Makefile.am
new file mode 100644
index 00000000..ce925aec
--- /dev/null
+++ b/modules/hebrew/Makefile.am
@@ -0,0 +1,23 @@
+## Process this file with automake to create Makefile.in.
+
+sources = hebrew-x.c
+
+if HAVE_X
+if INCLUDE_HEBREW_X
+noinst_LTLIBRARIES = libpango-hebrew-x.la
+moddefine = -DX_MODULE_PREFIX
+else
+moduledir = $(libdir)/pango/modules
+module_LTLIBRARIES = pango-hebrew-x.la
+moduleflags=-rpath $(libdir)
+endif
+endif
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/pango/ $(moddefine) $(X_CFLAGS)
+
+pango_hebrew_x_la_LDFLAGS = $(moduleflags) -export-dynamic -avoid-version -module
+pango_hebrew_x_la_LIBADD =
+pango_hebrew_x_la_SOURCES = $(sources)
+
+libpango_hebrew_x_la_SOURCES = $(sources)
+