summaryrefslogtreecommitdiff
path: root/modules/hebrew/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-14 23:48:34 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-14 23:48:34 +0000
commit402f2625c2c779df20470ed0f758999db494e4dc (patch)
tree6667e384ed0c39a22a6e3f731c062311fa7b3e9a /modules/hebrew/Makefile.am
parentf6fdd34661bd9fe23452b5eb98ece8488a12ce8f (diff)
downloadpango-402f2625c2c779df20470ed0f758999db494e4dc.tar.gz
Switch over the way that module entry points work, taking advantage of the
Mon Apr 14 06:02:34 2003 Owen Taylor <otaylor@redhat.com> * modules/thai/{thai-fc.c,thai-shaper.c,thai-x.c}: * modules/*/*-{xft,x,win32.c} pango/pango-engine.h modules/*/Makefile.am: Switch over the way that module entry points work, taking advantage of the new automake capability for per-target CFLAGS for shared sources. * pango/pangofc-font.[ch] pango/pangoxft-font.c pango/pangoft2.c: Add a base class for PangoXft and PangoFT2 font classes so code can be shared between FT2 and Xft backends. * configure.in modules/*/Makefile.am modules/{arabic,basic,hangul,hebrew,indic,thai}: Move *-xft.c to *-fc.c and share between Xft and FT2 backends; adds FT2 backend capabilities for hangul/indic/thai. * pango/pangoxft.h pango/pangoft2.h: Deprecate APIs that moved into PangoFcFont * modules/basic/basic-fc.c (set_glyph): Add kerning handling from FT2 backend.
Diffstat (limited to 'modules/hebrew/Makefile.am')
-rw-r--r--modules/hebrew/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/modules/hebrew/Makefile.am b/modules/hebrew/Makefile.am
index 8cc7fa7c..b486afd7 100644
--- a/modules/hebrew/Makefile.am
+++ b/modules/hebrew/Makefile.am
@@ -23,7 +23,6 @@ if HAVE_X
INCLUDES += $(X_CFLAGS)
if INCLUDE_HEBREW_X
noinst_LTLIBRARIES += libpango-hebrew-x.la
-INCLUDES += -DX_MODULE_PREFIX
else
module_LTLIBRARIES += pango-hebrew-x.la
endif
@@ -35,31 +34,32 @@ pango_hebrew_x_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_hebrew_x_la_LIBADD = $(pangoxlibs)
pango_hebrew_x_la_SOURCES = $(hebrew_x_sources)
libpango_hebrew_x_la_SOURCES = $(hebrew_x_sources)
+libpango_hebrew_x_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_hebrew_x
if HAVE_XFT
INCLUDES += $(XFT_CFLAGS)
if INCLUDE_HEBREW_XFT
noinst_LTLIBRARIES += libpango-hebrew-xft.la
-INCLUDES += -DXFT_MODULE_PREFIX
else
module_LTLIBRARIES += pango-hebrew-xft.la
endif
endif
-hebrew_xft_sources = $(common_sources) hebrew-xft.c
+hebrew_xft_sources = $(common_sources) hebrew-fc.c
pango_hebrew_xft_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_hebrew_xft_la_LIBADD = $(pangoxftlibs)
pango_hebrew_xft_la_SOURCES = $(hebrew_xft_sources)
+pango_hebrew_xft_la_CFLAGS = -DBUILD_XFT
libpango_hebrew_xft_la_SOURCES = $(hebrew_xft_sources)
+libpango_hebrew_xft_la_CFLAGS = -DBUILD_XFT -DPANGO_MODULE_PREFIX=_pango_hebrew_xft
if HAVE_FREETYPE
INCLUDES += $(FREETYPE_CFLAGS)
if INCLUDE_HEBREW_FT2
noinst_LTLIBRARIES += libpango-hebrew-ft2.la
-INCLUDES += -DFT2_MODULE_PREFIX
else
module_LTLIBRARIES += pango-hebrew-ft2.la
endif
@@ -69,12 +69,14 @@ if PLATFORM_WIN32
no_undefined = -no-undefined
endif
-hebrew_ft2_sources = $(common_sources) hebrew-ft2.c
+hebrew_ft2_sources = $(common_sources) hebrew-fc.c
pango_hebrew_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
pango_hebrew_ft2_la_LIBADD = $(pangoft2libs)
pango_hebrew_ft2_la_SOURCES = $(hebrew_ft2_sources)
+pango_hebrew_ft2_la_CFLAGS = -DBUILD_FT2
libpango_hebrew_ft2_la_SOURCES = $(hebrew_ft2_sources)
+libpango_hebrew_ft2_la_CFLAGS = -DBUILD_FT2 -DPANGO_MODULE_PREFIX=_pango_hebrew_ft2
included-modules: $(noinst_LTLIBRARIES)