summaryrefslogtreecommitdiff
path: root/modules/indic/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-14 23:56:21 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-14 23:56:21 +0000
commit996604e8144752146b98ebf5079c2dbfeb531e9e (patch)
tree55b183c3ed3b3a73fe7a24285557ac241afee637 /modules/indic/Makefile.am
parent5112146dc4f560563d8fb976adcd7a916d05785b (diff)
downloadpango-996604e8144752146b98ebf5079c2dbfeb531e9e.tar.gz
Add indic-ft2 module from Kapil Chowskey.
Mon Apr 14 07:52:25 2003 Owen Taylor <otaylor@redhat.com> * configure.in. modules/indic/Makefile.am modules/indic-ft2.c: Add indic-ft2 module from Kapil Chowskey.
Diffstat (limited to 'modules/indic/Makefile.am')
-rw-r--r--modules/indic/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/indic/Makefile.am b/modules/indic/Makefile.am
index f58ad78d..89e04b18 100644
--- a/modules/indic/Makefile.am
+++ b/modules/indic/Makefile.am
@@ -150,6 +150,27 @@ pango_indic_xft_la_SOURCES = $(xft_sources)
libpango_indic_xft_la_SOURCES = $(xft_sources)
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_INDIC_FT2
+noinst_LTLIBRARIES += libpango-indic-ft2.la
+INCLUDES += -DFREETYPE_MODULE_PREFIX
+else
+module_LTLIBRARIES += pango-indic-ft2.la
+endif
+endif
+
+ft2_sources = \
+ indic-ft2.c \
+ indic-ot-class-tables.c \
+ indic-ot.c \
+ indic-ot.h
+
+pango_indic_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module
+pango_indic_ft2_la_LIBADD = $(pangoft2libs)
+pango_indic_ft2_la_SOURCES = $(ft2_sources)
+libpango_indic_ft2_la_SOURCES = $(ft2_sources)
+
included-modules: $(noinst_LTLIBRARIES)
.PHONY: included-modules