summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-14 23:48:34 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-14 23:48:34 +0000
commit402f2625c2c779df20470ed0f758999db494e4dc (patch)
tree6667e384ed0c39a22a6e3f731c062311fa7b3e9a /modules/thai/Makefile.am
parentf6fdd34661bd9fe23452b5eb98ece8488a12ce8f (diff)
downloadpango-402f2625c2c779df20470ed0f758999db494e4dc.tar.gz
Switch over the way that module entry points work, taking advantage of the
Mon Apr 14 06:02:34 2003 Owen Taylor <otaylor@redhat.com> * modules/thai/{thai-fc.c,thai-shaper.c,thai-x.c}: * modules/*/*-{xft,x,win32.c} pango/pango-engine.h modules/*/Makefile.am: Switch over the way that module entry points work, taking advantage of the new automake capability for per-target CFLAGS for shared sources. * pango/pangofc-font.[ch] pango/pangoxft-font.c pango/pangoft2.c: Add a base class for PangoXft and PangoFT2 font classes so code can be shared between FT2 and Xft backends. * configure.in modules/*/Makefile.am modules/{arabic,basic,hangul,hebrew,indic,thai}: Move *-xft.c to *-fc.c and share between Xft and FT2 backends; adds FT2 backend capabilities for hangul/indic/thai. * pango/pangoxft.h pango/pangoft2.h: Deprecate APIs that moved into PangoFcFont * modules/basic/basic-fc.c (set_glyph): Add kerning handling from FT2 backend.
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am26
1 files changed, 23 insertions, 3 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index 7b66a756..82918faf 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -24,7 +24,6 @@ if HAVE_X
INCLUDES += $(X_CFLAGS)
if INCLUDE_THAI_X
noinst_LTLIBRARIES += libpango-thai-x.la
-INCLUDES += -DX_MODULE_PREFIX
else
module_LTLIBRARIES += pango-thai-x.la
endif
@@ -36,24 +35,45 @@ pango_thai_x_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_thai_x_la_LIBADD = $(pangoxlibs)
pango_thai_x_la_SOURCES = $(thai_x_sources)
libpango_thai_x_la_SOURCES = $(thai_x_sources)
+libpango_thai_x_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_x
if HAVE_XFT
INCLUDES += $(XFT_CFLAGS)
if INCLUDE_THAI_XFT
noinst_LTLIBRARIES += libpango-thai-xft.la
-INCLUDES += -DXFT_MODULE_PREFIX
else
module_LTLIBRARIES += pango-thai-xft.la
endif
endif
-thai_xft_sources = $(common_sources) thai-xft.c
+thai_xft_sources = $(common_sources) thai-fc.c
pango_thai_xft_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_thai_xft_la_LIBADD = $(pangoxftlibs)
pango_thai_xft_la_SOURCES = $(thai_xft_sources)
+pango_thai_xft_la_CFLAGS = -DBUILD_XFT
libpango_thai_xft_la_SOURCES = $(thai_xft_sources)
+libpango_thai_xft_la_CFLAGS = -DBUILD_XFT -DPANGO_MODULE_PREFIX=_pango_thai_xft
+
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_THAI_FT2
+noinst_LTLIBRARIES += libpango-thai-ft2.la
+else
+module_LTLIBRARIES += pango-thai-ft2.la
+endif
+endif
+
+thai_ft2_sources = $(common_sources) thai-fc.c
+
+pango_thai_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module
+pango_thai_ft2_la_LIBADD = $(pangoft2libs)
+pango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
+pango_thai_ft2_la_CFLAGS = -DBUILD_FT2
+libpango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
+libpango_thai_ft2_la_CFLAGS = -DBUILD_FT2 -DPANGO_MODULE_PREFIX=_pango_thai_ft2
included-modules: $(noinst_LTLIBRARIES)