summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-11-27 22:03:30 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-11-27 22:03:30 +0000
commit93d18a9135830d74bec50f04ca1723cb68c4ff1d (patch)
treee3c90745ee362565eda1c2a9503038e3a9990d5d /modules/thai/Makefile.am
parent7d36abc19331579d1a9d0df8b2c41a9bf57dd669 (diff)
downloadpango-93d18a9135830d74bec50f04ca1723cb68c4ff1d.tar.gz
Bug 371388 – Add Thai langauage engine Patch from Theppitak
2006-11-27 Behdad Esfahbod <behdad@gnome.org> Bug 371388 – Add Thai langauage engine Patch from Theppitak Karoonboonyanan * configure.in: Look for libthai and enable thai-lang module. * modules/thai/Makefile.am: Hook thai-lang module. * modules/thai/thai-lang.c: New Thai language engine that uses libthai to do dictionary-based Thai line-breaking. * examples/test-thai.txt: Improved.
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index 1b401357..40f2315c 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/modules/Module.mk
-common_sources = thai-charprop.c thai-charprop.h thai-shaper.c thai-shaper.h
+shaper_sources = thai-charprop.c thai-charprop.h thai-shaper.c thai-shaper.h
if HAVE_FREETYPE
INCLUDES += $(FREETYPE_CFLAGS)
@@ -13,10 +13,28 @@ endif
endif
endif
-thai_fc_sources = $(common_sources) thai-fc.c thai-ot.c thai-ot.h
+thai_fc_sources = $(shaper_sources) thai-fc.c thai-ot.c thai-ot.h
pango_thai_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
pango_thai_fc_la_LIBADD = $(pangoft2libs)
pango_thai_fc_la_SOURCES = $(thai_fc_sources)
libpango_thai_fc_la_SOURCES = $(thai_fc_sources)
libpango_thai_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_fc
+
+
+if INCLUDE_THAI_LANG
+noinst_LTLIBRARIES += libpango-thai-lang.la
+else
+if DYNAMIC_THAI_LANG
+module_LTLIBRARIES += pango-thai-lang.la
+endif
+endif
+
+lang_sources = \
+ thai-lang.c
+
+pango_thai_lang_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_thai_lang_la_LIBADD = $(pangolibs) $(LIBTHAI_LIBS)
+pango_thai_lang_la_SOURCES = $(lang_sources)
+libpango_thai_lang_la_SOURCES = $(lang_sources)
+libpango_thai_lang_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_lang $(LIBTHAI_CFLAGS)