summaryrefslogtreecommitdiff
path: root/pango-view/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2009-03-16 17:25:33 -0400
committerBehdad Esfahbod <behdad@behdad.org>2009-03-16 17:25:33 -0400
commitc82e8ad9dda142b1acfbcb86054750e082600893 (patch)
tree7dc3241e3a661718f770c0854658de18ee7300aa /pango-view/Makefile.am
parent69e1f7921525c2849d937b5a822475007a4f9a2f (diff)
downloadpango-c82e8ad9dda142b1acfbcb86054750e082600893.tar.gz
Bug 547963 – man page for pango-view
Diffstat (limited to 'pango-view/Makefile.am')
-rw-r--r--pango-view/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/pango-view/Makefile.am b/pango-view/Makefile.am
index 08bd4744..3ff5b5c3 100644
--- a/pango-view/Makefile.am
+++ b/pango-view/Makefile.am
@@ -37,6 +37,7 @@ INCLUDES = \
$(X_CFLAGS)
#########################################################
+
bin_PROGRAMS = pango-view
pango_view_SOURCES = \
viewer-render.h \
@@ -80,6 +81,31 @@ pango_view_LDADD += \
../pango/libpangocairo-$(PANGO_API_VERSION).la \
$(CAIRO_LIBS)
endif
+
+#########################################################
+
+MAINTAINERCLEANFILES = pango-view.1
+
+dist_man_MANS = pango-view.1
+
+$(srcdir)/pango-view.1: ../configure.in $(pango_view_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) pango-view
+ @echo "Creating $@ using help2man(1)"
+ @$(top_builddir)/missing --run \
+ help2man --no-info --section=1 \
+ --help-option="--help-all" --output="$@.tmp" \
+ --name 'Pango text viewer' ./pango-view \
+ && mv "$@.tmp" "$@" \
+ || ($(RM) "$@"; \
+ echo Failed to update pango-view.1, the man page may be outdated >&2; \
+ (test -f "$@" || echo help2man is required to generate this file. >> "$@"));
+
+install-data-hook:
+ @cd "$(DESTDIR)$(man1dir)" && gzip -c pango-view.1 > preload.1.gz && $(RM) preload.1
+
+uninstall-hook:
+ $(RM) "$(DESTDIR)$(man1dir)/pango-view.1.gz"
+
#########################################################
BUILT_SOURCES = pangorc