summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2000-12-14 23:23:14 +0000
committerHavoc Pennington <hp@src.gnome.org>2000-12-14 23:23:14 +0000
commit016c4d7047fd3ac2f76667f4ffe3b3a22ad0b902 (patch)
tree740872633a5f6f1ffda8dbf8a01e5249e9ff85de /pango/Makefile.am
parent1b3ed686bdc299ab5b79eeb8a485f6d84189f4e6 (diff)
downloadpango-016c4d7047fd3ac2f76667f4ffe3b3a22ad0b902.tar.gz
add assertion that shaper != NULL to catch engine problems faster
2000-12-14 Havoc Pennington <hp@redhat.com> * pango/fonts.c (pango_font_find_shaper): add assertion that shaper != NULL to catch engine problems faster * pango/Makefile.am (libpangox_la_SOURCES): modules.[hc] and module-defs.c have to go in libpangox for now since the modules use the X stuff, and static linkage won't let you play games here * examples/Makefile.am (pango_viewer_LDADD): fix order of link * modules/indic/pango-indic-script.h (pango_indic_get_char): make this a macro, so it doesn't collide between modules * modules/*/Makefile.am: Fix to work if the module isn't included * examples/Makefile.am: don't query modules if we didn't build any * modules/indic/gurmukhi.c (MODULE_ENTRY): fix prefix * modules/indic/bengali.c (MODULE_ENTRY): fix prefix * modules/indic/gujarati.c (MODULE_ENTRY): fix prefix * modules/indic/devanagari.c (MODULE_ENTRY): fix prefix * modules/indic/myanmar.c (MODULE_ENTRY): uniquely prefix the functions * modules/Makefile.am (MODULES): handle case where there are no modules to query * configure.in: Fix up include_modules stuff to work with Indic * pango/glyphstring.c (pango_glyph_string_set_size): Just g_error() if the glyph string exceeds maximum integer size, instead of mysteriously crashing later.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index a4e37ea8..4df0d880 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -18,9 +18,6 @@ libpango_la_SOURCES = \
fonts.c \
glyphstring.c \
mapping.c \
- modules.c \
- modules.h \
- module-defs.c \
pango-attributes.c \
pango-context.c \
pango-coverage.c \
@@ -36,6 +33,9 @@ libpango_la_SOURCES = \
shape.c
libpangox_la_SOURCES = \
+ modules.c \
+ modules.h \
+ module-defs.c \
pangox.c \
pangox-private.h \
pangox-fontcache.c \