summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-04-07 06:33:43 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-04-09 14:42:53 +0200
commit0fc06306063d8f3c8bd1e0d371eeb35ba9a9ea64 (patch)
tree68cc6fa4cf4fbaf9c764d104a840df14f18fc6b7 /pango/Makefile.am
parent4b16a0bf5c9795fe57255d5594a27c3cef634202 (diff)
downloadpango-0fc06306063d8f3c8bd1e0d371eeb35ba9a9ea64.tar.gz
build: move usp10 before gdi32
Without this pango on mingw64 tries to lookup up the Script* functions in gdi32 and fails. It already fails at the build stage because the introspection dump crashes with a missing entry point error. Moving usp10 before gdi32 makes things work. This might be related to the warning in the uniscribe docs: "Important Starting with Windows 8: To maintain the ability to run on Windows 7, a module that uses Uniscribe must specify Usp10.lib before gdi32.lib in its library list." https://bugzilla.gnome.org/show_bug.cgi?id=795045
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index 0ce84357..b360533d 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -393,7 +393,7 @@ libpangowin32_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS)
libpangowin32_1_0_la_LIBADD = \
libpango-$(PANGO_API_VERSION).la \
$(GLIB_LIBS) \
- -lgdi32 -lusp10
+ -lusp10 -lgdi32
libpangowin32_1_0_la_DEPENDENCIES = \
libpango-$(PANGO_API_VERSION).la
libpangowin32_1_0_la_SOURCES = \