summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2007-01-16 00:23:59 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2007-01-16 00:23:59 +0000
commit7a102793913cb7a1a0eefbbfc9d5c0d04c9eb868 (patch)
treed614b6941c83927af97a818fde59841499dd7917 /pango/Makefile.am
parentfd7ecbb0203d89f31e9b9b7c10147fa2a3864513 (diff)
downloadpango-7a102793913cb7a1a0eefbbfc9d5c0d04c9eb868.tar.gz
Bug 323173 – Add layout of mixed direction text for vertical layout
2007-01-15 Behdad Esfahbod <behdad@gnome.org> Bug 323173 – Add layout of mixed direction text for vertical layout * pango/pango-gravity.h: * pango/pango-gravity.c: Moved gravity stuff here. New public API: PangoGravityHint pango_gravity_get_for_matrix() pango_gravity_get_for_script() * pango/pango-context.h: * pango/pango-context.c (pango_context_init), (update_resolved_gravity), (itemize_state_update_for_new_run): Support gravity hint. New public API: pango_context_set_gravity_hint() pango_context_get_gravity_hint() * pango/pango-utils.c: * pango/pango-matrix.c: * pango/pango-matrix.h: * pango/pango-types.h: Moved gravity and matrix stuff into its own header. pango-types.h includes both pango-matrix.h and pango-gravity.h * pango/pango.h: Include new headers. * pango/pango.def: * pango/Makefile.am: Update. * docs/pango-docs.sgml: * docs/pango-sections.txt: * docs/tmpl/glyphs.sgml: * docs/tmpl/main.sgml: * docs/tmpl/vertical.sgml: Add a section for Vertical Text. * examples/renderdemo.c (do_output), (parse_gravity_hint), (parse_options): Support gravity hint. * examples/test-mixed.txt: New test, mixed Latin, Arabic, Chinese text. svn path=/trunk/; revision=2144
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index 59e1bcbc..9961d04d 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -77,18 +77,19 @@ libpango_1_0_la_SOURCES = \
pango-fontset.c \
pango-glyph-item.c \
pango-glyph-item-private.h \
+ pango-gravity.c \
pango-impl-utils.h \
pango-item.c \
pango-layout.c \
pango-layout-private.h \
pango-markup.c \
+ pango-matrix.c \
pango-renderer.c \
pango-script.c \
pango-script-lang-table.h \
pango-script-table.h \
pango-tabs.c \
pango-utils.c \
- pango-matrix.c \
reorder-items.c \
shape.c \
pango-enum-types.c \
@@ -106,16 +107,16 @@ pango_headers = \
pango-fontset.h \
pango-glyph.h \
pango-glyph-item.h \
+ pango-gravity.h \
pango-item.h \
pango-layout.h \
+ pango-matrix.h \
pango-modules.h \
pango-renderer.h \
pango-script.h \
pango-tabs.h \
pango-types.h \
- pango-utils.h \
- pangofc-font.h \
- pangofc-fontmap.h
+ pango-utils.h
pangoinclude_HEADERS = \
$(pango_headers) \
@@ -183,6 +184,7 @@ libpangox_1_0_la_SOURCES = \
# ------------------- libpangoft2 -------------------
if HAVE_FREETYPE
+pangoinclude_HEADERS += pangofc-font.h pangofc-fontmap.h
pangoinclude_HEADERS += pangoft2.h pango-ot.h pangofc-decoder.h
lib_LTLIBRARIES += libpangoft2-1.0.la
endif