summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-10-03 06:18:15 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-10-03 06:18:15 +0000
commit5c3dee45a584a81d800ffc8291b9169af6d790c0 (patch)
treef5b5614634e91472fc15219ea301da7f4cc247c8 /pango/Makefile.am
parent3346b3802575f161ac9880a3ca08a3f772eb7e0d (diff)
downloadpango-5c3dee45a584a81d800ffc8291b9169af6d790c0.tar.gz
Add the Win32 GDI Pango backend to autoconfiguration:
2001-10-03 Tor Lillqvist <tml@iki.fi> Add the Win32 GDI Pango backend to autoconfiguration: * configure.in: Call AC_LIBTOOL_WIN32_DLL. Check for native Win32 or Cygwin, set automake conditional PLATFORM_WIN32. Check for native Win32, set OS_WIN32. Refactor the Xrender+Xft+Xft+FreeType.h checks not to use AC_CHECK_LIBs inside eachother, autoconf 2.52e on Cygwin generated bad shell code for that. Check for gdi32 library, set automake conditional HAVE_WIN32. Add the basic-win32 module, add INCLUDED_WIN32_MODULES and INCLUDE_BASIC_WIN32. Write pango/module-defs-win32.c. Generate pangowin32*.pc. * pangowin32.pc.in * pangowin32-uninstalled.pc.in: New files. * Makefile.am: Add pangowin32*.pc.in. * .cvsignore: Add pangowin32*.pc. * modules/basic/Makefile.am: Add the basic-win32 backend. Use -no-undefined on PLATFORM_WIN32. * pango/Makefile.am: Add the Win32 backend. Use -no-undefined on PLATFORM_WIN32. Use the .def files on OS_WIN32. Link libpangoft2 with GLIB_LIBS. * pango/pango-utils.c: (DllMain): New function, on G_OS_WIN32. Used to get the actual DLL name, which is tucked away. (pango_get_sysconf_subdirectory, pango_get_lib_subdirectory): (Win32): Append VERSION to the registry key passed to g_win32_get_package_installation_subdirectory(). Use the real DLL name from above instead of assuming the DLL has a certain name. Other Win32 backend fixes: * pango/pangowin32-fontmap.c: (free_coverages_foreach): Remove, unused. * pango/pangowin32.c: Remove unused variables. * pango/pangowin32.def: Add pango_win32_font_get_glyph_index. * pango/pangowin32.h: Remove pango_win32_font_get_coverage, which is static.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am41
1 files changed, 33 insertions, 8 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index d00dac0f..303c5564 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -34,6 +34,14 @@ X_HFILES=
X_BUILD_LIBS=
endif
+if HAVE_WIN32
+WIN32_HFILES=pangowin32.h
+WIN32_BUILD_LIBS=libpangowin32.la
+else
+WIN32_HFILES=
+WIN32_BUILD_LIBS=
+endif
+
if HAVE_XFT
XFT_HFILES=pangoxft.h pango-ot.h
XFT_BUILD_LIBS=libpangoxft.la
@@ -50,8 +58,17 @@ FT2_BUILD_LIBS=
FT2_HFILES=
endif
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+endif
-lib_LTLIBRARIES = libpango.la $(X_BUILD_LIBS) $(XFT_BUILD_LIBS) $(FT2_BUILD_LIBS)
+if OS_WIN32
+pango_export_symbols = -export-symbols pango.def
+pangowin32_export_symbols = -export-symbols pangowin32.def
+pangoft2_export_symbols = -export-symbols pangoft2.def
+endif
+
+lib_LTLIBRARIES = libpango.la $(X_BUILD_LIBS) $(WIN32_BUILD_LIBS) $(XFT_BUILD_LIBS) $(FT2_BUILD_LIBS)
bin_PROGRAMS = pango-querymodules
@@ -95,7 +112,7 @@ libpangox_la_SOURCES = \
# down at which point we'll either use the GTK+ versioning
# scheme or the standard libtool scheme.
#
-libpango_la_LDFLAGS = -release $(VERSION) $(GLIB_LIBS)
+libpango_la_LDFLAGS = -release $(VERSION) $(GLIB_LIBS) $(no_undefined) $(pango_export_symbols)
if HAVE_FRIBIDI
else
libpango_la_LIBADD = mini-fribidi/libmini-fribidi.la
@@ -105,6 +122,19 @@ libpangox_la_LDFLAGS = -release $(VERSION)
libpangox_la_LIBADD = $(INCLUDED_X_MODULES) $(X_LIBS) libpango.la
libpangox_la_DEPENDENCIES = $(INCLUDED_X_MODULES) libpango.la
+libpangowin32_la_SOURCES = \
+ pangowin32.h \
+ pangowin32.c \
+ pangowin32-private.h \
+ pangowin32-fontcache.c \
+ pangowin32-fontmap.c \
+ module-defs-win32.c
+
+libpangowin32_la_LDFLAGS = -release $(VERSION) $(GLIB_LIBS) $(no_undefined) $(pangowin32_export_symbols)
+libpangowin32_la_LIBADD = $(INCLUDED_WIN32_MODULES) $(WIN32_LIBS) libpango.la
+libpangowin32_la_DEPENDENCIES = libpango.la
+
+
libpangoxft_la_SOURCES = \
pangoxft-font.c \
pangoxft-fontmap.c \
@@ -124,7 +154,7 @@ libpangoft2_la_SOURCES = \
module-defs-ft2.c
libpangoft2_la_LIBADD = $(INCLUDED_FT2_MODULES) $(FREETYPE_LIBS) libpango.la
-libpangoft2_la_LDFLAGS = -release $(VERSION)
+libpangoft2_la_LDFLAGS = -release $(VERSION) $(GLIB_LIBS) $(no_undefined) $(pangoft2_export_symbols)
libpangoft2_la_DEPENDENCIES = $(INCLUDED_FT2_MODULES) libpango.la
pangoincludedir=$(includedir)/pango-1.0/pango
@@ -204,11 +234,6 @@ EXTRA_DIST = \
module-defs.h \
pango.def \
pangowin32.def \
- pangowin32.h \
- pangowin32.c \
- pangowin32-private.h \
- pangowin32-fontcache.c \
- pangowin32-fontmap.c \
pangoft2.def \
makefile.mingw \
makefile.mingw.in \