summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-04-14 23:48:34 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-04-14 23:48:34 +0000
commit402f2625c2c779df20470ed0f758999db494e4dc (patch)
tree6667e384ed0c39a22a6e3f731c062311fa7b3e9a /pango/Makefile.am
parentf6fdd34661bd9fe23452b5eb98ece8488a12ce8f (diff)
downloadpango-402f2625c2c779df20470ed0f758999db494e4dc.tar.gz
Switch over the way that module entry points work, taking advantage of the
Mon Apr 14 06:02:34 2003 Owen Taylor <otaylor@redhat.com> * modules/thai/{thai-fc.c,thai-shaper.c,thai-x.c}: * modules/*/*-{xft,x,win32.c} pango/pango-engine.h modules/*/Makefile.am: Switch over the way that module entry points work, taking advantage of the new automake capability for per-target CFLAGS for shared sources. * pango/pangofc-font.[ch] pango/pangoxft-font.c pango/pangoft2.c: Add a base class for PangoXft and PangoFT2 font classes so code can be shared between FT2 and Xft backends. * configure.in modules/*/Makefile.am modules/{arabic,basic,hangul,hebrew,indic,thai}: Move *-xft.c to *-fc.c and share between Xft and FT2 backends; adds FT2 backend capabilities for hangul/indic/thai. * pango/pangoxft.h pango/pangoft2.h: Deprecate APIs that moved into PangoFcFont * modules/basic/basic-fc.c (set_glyph): Add kerning handling from FT2 backend.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index b0702b26..66d5d9e9 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -78,6 +78,7 @@ libpango_1_0_la_SOURCES = \
pango-markup.c \
pango-tabs.c \
pango-utils.c \
+ pangofc-font.c \
reorder-items.c \
shape.c \
pango-enum-types.c
@@ -100,7 +101,8 @@ pango_headers = \
pango-modules.h \
pango-tabs.h \
pango-types.h \
- pango-utils.h
+ pango-utils.h \
+ pangofc-font.h
pangoinclude_HEADERS = \
$(pango_headers) \