summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2009-10-22 17:24:21 -0400
committerBehdad Esfahbod <behdad@behdad.org>2009-10-22 17:24:21 -0400
commit1038b7959944dd25d7c2a76a3c769eb26b5fd6a2 (patch)
treeedcf29ea49fd04154c54f7cd0ef5a6b272bca69e /pango/Makefile.am
parent72b3642ec8f689eee5463ae8675323d91496238e (diff)
downloadpango-1038b7959944dd25d7c2a76a3c769eb26b5fd6a2.tar.gz
Allow using uninstalled glib
Reported by mpsuzuki on gtk-i18n-list on 2009-10-09.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index bce92c40..ef0245c0 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -133,7 +133,7 @@ pangoinclude_HEADERS = \
pango-enum-types.h: s-enum-types-h
$(AM_V_GEN) true
s-enum-types-h: @REBUILD@ $(pango_headers) Makefile
- $(AM_V_GEN) ( cd $(srcdir) && glib-mkenums \
+ $(AM_V_GEN) ( cd $(srcdir) && $(GLIB_MKENUMS) \
--fhead "#ifndef __PANGO_ENUM_TYPES_H__\n#define __PANGO_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
--fprod "/* enumerations from \"@filename@\" */\n" \
--vhead "GType @enum_name@_get_type (void);\n#define @ENUMPREFIX@_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
@@ -146,7 +146,7 @@ s-enum-types-h: @REBUILD@ $(pango_headers) Makefile
pango-enum-types.c: s-enum-types-c
$(AM_V_GEN) true
s-enum-types-c: @REBUILD@ $(pango_headers) Makefile
- $(AM_V_GEN) ( cd $(srcdir) && glib-mkenums \
+ $(AM_V_GEN) ( cd $(srcdir) && $(GLIB_MKENUMS) \
--fhead "#include <pango.h>" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \