summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-06-30 22:08:26 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-06-30 22:08:26 +0000
commitb49e8181c16e91afc0b2e771243f9adab9bc8b5d (patch)
treef3b463eec927649a43bd0b22464a5118f0b0d4a7 /pango/Makefile.am
parent036da71c38c9d81a087f20079cc7b96154fc5a3c (diff)
downloadpango-b49e8181c16e91afc0b2e771243f9adab9bc8b5d.tar.gz
A bunch of simple functions for reading from files, manipulating strings
Fri Jun 30 16:46:31 2000 Owen Taylor <otaylor@redhat.com> * pango/pango-utils.[ch] Makefile.am: A bunch of simple functions for reading from files, manipulating strings as necessary for config files. Also, a simple gnome-config/win.ini style config file reader. * pango/modules.c: Remove DOTFILES stuff. Instead, read names of modules file from pangorc. (Which can be set from PANGO_RC_FILE). Rewrite parsing code using pango-utils.c. * pango/pangox-fontmap.c: Read list of files from PangoX/AliasFiles key. Rewrite parsing code for alias files using pango-utils.c. * examples/pangox.aliases: Move to new name from pangox_aliases, reformat using new parsing code. * examples/pangorc (AliasFiles) examples/pango-viewer: Add a pangorc file for in-place testing. * pango/querymodules.c (main): Add comment to the top of the output indicating that the file should not be hand-edited.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index ea86de71..ee0961bc 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to create Makefile.in.
-INCLUDES=-DDOTMODULEDIR=\"$(sysconfdir)/pango\" -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DLOCALSTATEDIR=\"$(localstatedir)\" -I$(top_srcdir)
+INCLUDES=-DSYSCONFDIR=\"$(sysconfdir)\" -DLIBDIR=\"$(libdir)\"
+ -I$(top_srcdir)
lib_LTLIBRARIES = libpango.la libpangox.la
bin_PROGRAMS = pango-querymodules
@@ -20,6 +20,7 @@ libpango_la_SOURCES = \
pango-fontmap.c \
pango-item.c \
pango-layout.c \
+ pango-utils.c \
reorder-items.c \
shape.c
@@ -53,6 +54,7 @@ pangoinclude_HEADERS = \
pango-layout.h \
pango-modules.h \
pango-types.h \
+ pango-utils.h \
pangox.h
#