summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2000-08-21 13:21:03 +0000
committerTor Lillqvist <tml@src.gnome.org>2000-08-21 13:21:03 +0000
commit91d66774aa844a8df1ea0311d71b82059d8c3581 (patch)
treef75681b9a03e9dadc8451f317549e2ad980ebd6a /pango/Makefile.am
parentcd3238a63b904fd0792ca04f1dac7ff04ef98eb4 (diff)
downloadpango-91d66774aa844a8df1ea0311d71b82059d8c3581.tar.gz
Get font directory path with pango_config_key_get("PangoFT2/FontPath"). If
2000-08-21 Tor Lillqvist <tml@iki.fi> * pango/pangoft2-fontmap.c: Get font directory path with pango_config_key_get("PangoFT2/FontPath"). If no such key exists in the pangorc file, use the ft2fonts subdirectory of LIBDIR/pango, and on Windows, also %WinDir%\fonts. * pango/{pango,pangoft2,pangowin32}.rc.in: New files (resource files used when building Win32 DLLs, contain version information). * pango/Makefile.am: Add the new files. * configure.in: Define major and minor version numbers separately. Output also the makefile.mingw and *.rc files.
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
index fb19cd43..53f2802e 100644
--- a/pango/Makefile.am
+++ b/pango/Makefile.am
@@ -79,7 +79,23 @@ EXTRA_DIST = \
pangoft2-fontcache.c \
pangoft2-fontmap.c \
makefile.mingw \
- makefile.mingw.in
+ makefile.mingw.in \
+ pango.rc \
+ pango.rc.in \
+ pangoft2.rc \
+ pangoft2.rc.in \
+ pangowin32.rc \
+ pangowin32.rc.in
+
makefile.mingw: $(top_builddir)/config.status $(top_srcdir)/pango/makefile.mingw.in
cd $(top_builddir) && CONFIG_FILES=pango/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+pango2.rc: $(top_builddir)/config.status $(top_srcdir)/pango/pango.rc.in
+ cd $(top_builddir) && CONFIG_FILES=pango/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+pangoft2.rc: $(top_builddir)/config.status $(top_srcdir)/pango/pangoft2.rc.in
+ cd $(top_builddir) && CONFIG_FILES=pango/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+pangowin32.rc: $(top_builddir)/config.status $(top_srcdir)/pango/pangowin32.rc.in
+ cd $(top_builddir) && CONFIG_FILES=pango/$@ CONFIG_HEADERS= $(SHELL) ./config.status