summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2018-10-04 11:11:48 +0000
committerKhaled Hosny <khaledhosny@eglug.org>2018-10-04 11:11:48 +0000
commit962cf9a41942f998e25d5d22b2110b85b670b718 (patch)
tree366235d258b3cd92885a35d451eb2ef783fc0d1e /pango/meson.build
parentcf0516835b3d4b57d99779917d5449dae3a207cc (diff)
parent1ce6fc1c349afce1b7c04e02388b3caed7d46f7d (diff)
downloadpango-962cf9a41942f998e25d5d22b2110b85b670b718.tar.gz
Merge branch 'fix-build-osx' into 'master'
meson: fix build on osx Closes #324 See merge request GNOME/pango!21
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/pango/meson.build b/pango/meson.build
index f8b484a5..254b169a 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -112,7 +112,7 @@ libpango = library(
version: pango_libversion,
soversion: pango_soversion,
install: true,
- dependencies: [ gobject_dep, mathlib_dep, thai_dep, fribidi_dep ],
+ dependencies: pango_deps,
include_directories: [ root_inc, pango_inc ],
c_args: common_cflags + pango_debug_cflags + pango_cflags,
link_args: common_ldflags,
@@ -442,7 +442,6 @@ if cairo_dep.found()
'pangocairo-coretextfont.c',
'pangocairo-coretextfontmap.c',
]
- pangocairo_deps += dependency('appleframeworks', modules: [ 'CoreFoundation', 'ApplicationServices' ])
endif
install_headers(pangocairo_headers, subdir: pango_api_path)