summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2019-07-19 18:15:12 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2019-07-19 18:15:12 +0800
commit039f842773df8e5cb56c8840d2741bbc321a3ed7 (patch)
tree68255cd8298534ef62374b2679cc962618d06531 /pango/meson.build
parent24e079c3ef47702a38266d404aac204b701038ad (diff)
downloadpango-039f842773df8e5cb56c8840d2741bbc321a3ed7.tar.gz
pango/meson.build: Fix pangocairo.pc on MSVC builds
On MSVC builds, Cairo may be found either via pkg-config files or manually through finding headers and libs, so we need to ensure that we create pangocairo.pc correctly, otherwise items that depend on PangoCairo may not link correctly.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/pango/meson.build b/pango/meson.build
index cfbf8a9a..e47fded2 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -490,13 +490,21 @@ if cairo_dep.found()
sources: pangocairo_dep_sources,
)
+ # Create pangocairo.pc according to whether we found Cairo
+ # manually
+ if ['pkgconfig', 'internal'].contains(cairo_found_type)
+ pango_cairo_requires = [ 'pango', cairo_pc ]
+ else
+ pango_cairo_requires = [ 'pango' ]
+ endif
+
pkgconfig.generate(libpangocairo,
name: 'Pango Cairo',
description: 'Cairo rendering support for Pango',
version: meson.project_version(),
filebase: 'pangocairo',
subdirs: pango_api_name,
- requires: [ 'pango', cairo_pc ],
+ requires: pango_cairo_requires,
install_dir: join_paths(pango_libdir, 'pkgconfig'),
)
else