summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2022-07-06 16:58:41 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2022-09-26 11:04:25 +0800
commit0cebf7cf50c49ea30f00bdce724d290e43b8e29d (patch)
tree57ab0254c4cb66fa35a4c806eebd151bbc9fe350 /pango/meson.build
parentf2add41dadacd7cb2df804a2e7faa670c8db69ee (diff)
downloadpango-0cebf7cf50c49ea30f00bdce724d290e43b8e29d.tar.gz
build: Check for DirectWrite support
...in Cairo, as well as their presence in the Windows SDKs (which should always be there in the Windows SDKs). We want to use items in DirectWrite to help us improve support on Windows regarding looking up for features (description) of a font. Since upstream Cairo gained DirectWrite support very recently, check for it only via pkg-config, since Cairo had Meson build support quite a bit before that happened.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 1a4b4141..d6b2d81c 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -429,6 +429,7 @@ if host_system == 'windows'
pangowin32_deps = pango_deps + [
libpango_dep,
cc.find_library('gdi32'),
+ cc.find_library('dwrite'),
]
pangowin32_rc = configure_file(