summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-05-19 11:58:44 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-19 17:32:28 +0100
commit09623d50ac8afd9b246e571372972142af5daaa3 (patch)
tree6d111164637f3756a3c2d90018763b5dafbf02e9 /pango/meson.build
parent5d3af9bf597cf42bd39bf2e4275c7f0746a947b5 (diff)
downloadpango-09623d50ac8afd9b246e571372972142af5daaa3.tar.gz
meson: Add a few missing things, minor fixes, TODO
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/pango/meson.build b/pango/meson.build
index bbc6a579..9e9756b6 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -242,7 +242,7 @@ if xft_dep.found()
endif
# Win32
-if host_system.contains('windows')
+if host_system == 'windows'
pangowin32_headers = [
'pangowin32.h',
]
@@ -306,7 +306,7 @@ if cairo_dep.found()
pangocairo_gir_deps += pangoft2_gir_dep
endif
- if host_system.contains('windows') and pango_font_backends.contains('win32')
+ if host_system == 'windows' and pango_font_backends.contains('win32')
pangocairo_sources += [
'pangocairo-win32font.c',
'pangocairo-win32fontmap.c',
@@ -315,7 +315,7 @@ if cairo_dep.found()
pangocairo_deps += libpangowin32_dep
endif
- if host_system.contains('darwin') and pango_font_backends.contains('quartz')
+ if host_system == 'darwin' and pango_font_backends.contains('quartz')
pangocairo_sources += [
'pangocoretext.c',
'pangocoretext-fontmap.c',