summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-04-07 06:33:43 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-04-09 14:42:53 +0200
commit0fc06306063d8f3c8bd1e0d371eeb35ba9a9ea64 (patch)
tree68cc6fa4cf4fbaf9c764d104a840df14f18fc6b7 /pango/meson.build
parent4b16a0bf5c9795fe57255d5594a27c3cef634202 (diff)
downloadpango-0fc06306063d8f3c8bd1e0d371eeb35ba9a9ea64.tar.gz
build: move usp10 before gdi32
Without this pango on mingw64 tries to lookup up the Script* functions in gdi32 and fails. It already fails at the build stage because the introspection dump crashes with a missing entry point error. Moving usp10 before gdi32 makes things work. This might be related to the warning in the uniscribe docs: "Important Starting with Windows 8: To maintain the ability to run on Windows 7, a module that uses Uniscribe must specify Usp10.lib before gdi32.lib in its library list." https://bugzilla.gnome.org/show_bug.cgi?id=795045
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 3312d72d..25b939f7 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -304,10 +304,12 @@ if host_system == 'windows'
'pangowin32-shape.c',
]
+ # usp10 needs to be before gdi32
+ # see https://bugzilla.gnome.org/show_bug.cgi?id=795045#c0
pangowin32_deps = pango_deps + [
libpango_dep,
- cc.find_library('gdi32'),
cc.find_library('usp10'),
+ cc.find_library('gdi32'),
]
pangowin32_rc = configure_file(