summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-11-11 20:15:25 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-12-03 18:53:40 +0800
commit497ee87d5105fb3b6a957abdaf4754ab1d6c6533 (patch)
tree1cdb5930ef0f942e8936f0a57b51e6314820ad26 /pango/meson.build
parent66e2ea5f428893e102fe2cbaa45de0852118f5e2 (diff)
downloadpango-497ee87d5105fb3b6a957abdaf4754ab1d6c6533.tar.gz
PangoWin32: Initialize DirectWrite as wellwin32-font-language
We want to start using DirectWrite to help us implement some features that are not that easily done with GDI/Uniscribe, via a GDI interop layer as provided by DirectWrite, and by creating and keeping track of the IDWriteFont's that are created from each of the LOGFONTs that we acquire by quering the fonts that is installed on the system.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 91261274..21b620ec 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -413,6 +413,7 @@ if host_system == 'windows'
pangowin32_deps = pango_deps + [
libpango_dep,
cc.find_library('gdi32'),
+ cc.find_library('dwrite'),
]
pangowin32_rc = configure_file(