summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-08-30 16:11:00 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-08-30 16:16:03 +0100
commit98be56d131dc7aa2cb95cbe1d4ea646cb6e924b8 (patch)
tree6eec81c6d447107ba1063d74d1d5e102d1f4e29e /pango/meson.build
parentb6d1048a2631cd4703b43550da5228b724858ee4 (diff)
downloadpango-98be56d131dc7aa2cb95cbe1d4ea646cb6e924b8.tar.gz
build: Add variable for the Pango versioned space
We have the API version and we build the inclusion path from it, but we should have a variable with the versioned namespace ('pango' + API version) and build paths using join_paths() instead. We're also going to use the versioned namespace elsewhere soon.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/pango/meson.build b/pango/meson.build
index c44853de..537b6bca 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -107,7 +107,7 @@ pango_cflags = [
pango_inc = include_directories('.')
libpango = library(
- 'pango-@0@'.format(pango_api_version),
+ pango_api_name,
sources: pango_sources + pango_enums,
version: pango_libversion,
soversion: pango_soversion,