summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-09-29 11:00:45 -0400
committerXavier Claessens <xavier.claessens@collabora.com>2020-09-29 19:33:09 -0400
commit82cfabbabaade239beb26136cb28c98156552ea5 (patch)
tree7446c1387beb99674f64edf10205fe7f7e5eda3f /pango/meson.build
parent86516a454fb71b1a6564b4e76174503711eed05b (diff)
downloadpango-82cfabbabaade239beb26136cb28c98156552ea5.tar.gz
meson: Change introspection option to yielding feature
Yielding option means that if pango is built as a subproject, it will take the value of that option from the parent project (e.g. gst-build). For that to work it must be of the same type, which is "feature" instead of "boolean" in all GStreamer modules.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 4c055f52..0b87b644 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -121,7 +121,8 @@ libpango = library(
pango_dep_sources = [pango_enum_h]
-build_gir = get_option('introspection')
+gir = find_program('g-ir-scanner', required : get_option('introspection'))
+build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
if build_gir
gir_args = [