summaryrefslogtreecommitdiff
path: root/pango/mini-fribidi/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2010-02-10 15:30:12 +0200
committerTor Lillqvist <tml@iki.fi>2010-03-15 23:25:26 +0200
commitb68d520e9ff526be4301f6db09c0faa077cd864a (patch)
tree2a5d959733f966f72b0b128799fa35b184b0ddf4 /pango/mini-fribidi/Makefile.am
parent6118d5891fee776a087855c335a73c79fdaf036c (diff)
downloadpango-b68d520e9ff526be4301f6db09c0faa077cd864a.tar.gz
Add solution and project files for Visual Studio builds
The VS files are kept in build/win32/vs9, the same relative location as in GLib, mostly for historical reasons. Update README.win32 to reflect the VS possibility. Include the VS solution and project files in the tarball when doing a release. To avoid having to list source files in several locations, generate files listing source files at "make dist" time in the corresponding source directories. Use the C preprocessor to preprocess .vcprojin files that include said list files into the actual .vcproj project files. Provide a rc file for the pangocairo DLL, too. Construct and provide in the tarball a pregenerated config.h.win32 which can be used as config.h when building with Visual C without running any configure script. Provide pregenerarated module-defs.h.win32, module-defs-lang.c.win32 files too. Define PANGO_MODULE_PREFIX appropriately in the relevant module source files if not available from the compilation command line. Update module-defs-fc.c.win32 and module-defs-win32.c.win32 to match what the configure script provides.
Diffstat (limited to 'pango/mini-fribidi/Makefile.am')
-rw-r--r--pango/mini-fribidi/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/pango/mini-fribidi/Makefile.am b/pango/mini-fribidi/Makefile.am
index a9e08d6e..a0baa6b0 100644
--- a/pango/mini-fribidi/Makefile.am
+++ b/pango/mini-fribidi/Makefile.am
@@ -30,4 +30,14 @@ EXTRA_DIST = \
fribidi_types.i
+dist-hook: libmini-fribidi.sourcefiles
+
+libmini-fribidi.sourcefiles: Makefile
+ for F in $(libmini_fribidi_la_SOURCES); do \
+ case $$F in \
+ *.c) echo ' <File RelativePath="..\..\..\pango\mini-fribidi\'$$F'" />' \
+ ;; \
+ esac; \
+ done >libmini-fribidi.sourcefiles
+
-include $(top_srcdir)/git.mk