summaryrefslogtreecommitdiff
path: root/pango/opentype/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-03-31 12:28:09 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-03-31 12:28:09 +0000
commit9e6a19d45496ead8334bc24d89f5208da9e30e8b (patch)
tree0b965c31595c72772dd3424a0c27da0ed5a28ee0 /pango/opentype/Makefile.am
parent199ae3899424429340d77c908eacb921d4499aa1 (diff)
downloadpango-9e6a19d45496ead8334bc24d89f5208da9e30e8b.tar.gz
Convert pango/opentype to the new project called HarfBuzz.
2006-03-31 Behdad Esfahbod <behdad@gnome.org> Convert pango/opentype to the new project called HarfBuzz. * pango/opentype/*: Restructured. * pango/pango-ot-*: Updated to use HarfBuzz symbol names.
Diffstat (limited to 'pango/opentype/Makefile.am')
-rw-r--r--pango/opentype/Makefile.am89
1 files changed, 48 insertions, 41 deletions
diff --git a/pango/opentype/Makefile.am b/pango/opentype/Makefile.am
index 7c0ba69c..8d65294e 100644
--- a/pango/opentype/Makefile.am
+++ b/pango/opentype/Makefile.am
@@ -1,51 +1,58 @@
## Process this file with automake to produce Makefile.in
INCLUDES = \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DLIBDIR=\"$(libdir)\" \
- $(PANGO_DEBUG_FLAGS) \
- -I$(top_srcdir) \
- $(GLIB_CFLAGS) \
$(FREETYPE_CFLAGS)
-noinst_LTLIBRARIES = libmini-harfbuzz.la
-
-libmini_harfbuzz_la_SOURCES = \
- ftglue.h \
- ftglue.c \
- ftxopen.c \
- ftxopen.h \
- ftxopenf.h \
- ftxgdef.c \
- ftxgdef.h \
- ftxgpos.c \
- ftxgpos.h \
- ftxgsub.c \
- ftxgsub.h \
- otlbuffer.c \
- otlbuffer.h
-
-libmini_harfbuzz_la_LIBADD = \
- $(x_ldflags) \
- $(x_libs) \
- $(GLIB_LIBS) \
- -lm
-
-if BUILD_OT_TESTS
-noinst_PROGRAMS = ottest
-endif
-
-ottest_SOURCES = \
- ottest.c \
- disasm.c \
- disasm.h
-
-ottest_LDADD = \
- libmini-harfbuzz.la \
+noinst_LTLIBRARIES = libharfbuzz-1.la
+
+SOURCES = \
+ ftglue.c \
+ harfbuzz-buffer.c \
+ harfbuzz-dump.c \
+ harfbuzz-gdef.c \
+ harfbuzz-gpos.c \
+ harfbuzz-gsub.c \
+ harfbuzz-open.c
+
+EXTRA_SOURCES = harfbuzz.c
+
+PUBLICHEADERS = \
+ harfbuzz.h \
+ harfbuzz-buffer.h \
+ harfbuzz-dump.h \
+ harfbuzz-gdef.h \
+ harfbuzz-gpos.h \
+ harfbuzz-gsub.h \
+ harfbuzz-open.h
+
+PRIVATEHEADERS = \
+ ftglue.h \
+ harfbuzz-impl.h \
+ harfbuzz-gdef-private.h \
+ harfbuzz-gpos-private.h \
+ harfbuzz-gsub-private.h \
+ harfbuzz-open-private.h
+
+libharfbuzz_1_la_SOURCES = \
+ $(SOURCES) \
+ $(PUBLICHEADERS) \
+ $(PRIVATEHEADERS)
+
+libharfbuzz_1_la_LIBADD = \
$(FREETYPE_LIBS)
+noinst_PROGRAMS = harfbuzz-dump
+
+harfbuzz_dump_SOURCES = \
+ harfbuzz-dump-main.c
+
+harfbuzz_dump_LDADD = \
+ libharfbuzz-1.la
+
EXTRA_DIST = \
README \
- FTL.TXT \
- FT-license.txt
+ COPYING.FTL \
+ COPYING.GPL \
+ COPYING \
+ $(EXTRA_SOURCES)