summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-11-27 00:27:51 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-11-27 00:27:51 +0000
commite369baa4f65aaceb31d8aeaf322e5d1fe0869311 (patch)
tree0a08e010ece11fde215e77e18f2f0d3082a8c4df /tests/Makefile.am
parent8eb8470fde676c147a76e406e1fb2c66a00d016b (diff)
downloadpango-e369baa4f65aaceb31d8aeaf322e5d1fe0869311.tar.gz
Add a test program that includes all headers in a C++ program. (#52606)
Mon Nov 26 19:24:21 2001 Owen Taylor <otaylor@redhat.com> * configure.in tests/Makefile.am tests/cxx-test.C: Add a test program that includes all headers in a C++ program. (#52606)
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am43
1 files changed, 41 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 16bca8a8..aabc7afc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,44 @@
## Process this file with automake to create Makefile.in.
-INCLUDES = -I$(top_srcdir) $(GLIB_CFLAGS)
+if HAVE_XFT
+X_DEFINES=-DHAVE_X
+else
+X_DEFINES=
+endif
+
+if HAVE_XFT
+XFT_DEFINES=-DHAVE_XFT
+else
+XFT_DEFINES=
+endif
+
+if HAVE_FREETYPE
+FT2_DEFINES=-DHAVE_FREETYPE
+else
+FT2_DEFINES=
+endif
+
+if HAVE_WIN32
+WIN32_DEFINES=-DHAVE_WIN32
+else
+WIN32_DEFINES=
+endif
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(GLIB_CFLAGS) \
+ $(X_CFLAGS) \
+ $(FREETYPE_CFLAGS) \
+ $(X_DEFINES) \
+ $(XFT_DEFINES) \
+ $(FT2_DEFINES) \
+ $(WIN32_DEFINES)
TESTS=runtests.sh
noinst_PROGRAMS = gen-all-unicode dump-boundaries
-check_PROGRAMS = testboundaries
+check_PROGRAMS = testboundaries $(CXX_TEST)
gen_all_unicode_SOURCES = gen-all-unicode.c
@@ -20,6 +52,13 @@ testboundaries_LDADD = ../pango/libpango.la
dump_boundaries_LDADD = ../pango/libpango.la
+if HAVE_CXX
+CXX_TEST = cxx-test
+cxx_test_SOURCES = cxx-test.C
+else
+CXX_TEST =
+endif
+
EXTRA_DIST = \
all-unicode.txt \
boundaries.utf8 \