summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2007-05-10 21:26:21 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2007-05-10 21:26:21 +0000
commitdd0245c7629630c52a33f301ce5ba687ec353cff (patch)
treefefc5c8f24a7ad1fd4db35a1e33fe4fcce78a276 /tests/Makefile.am
parentf20dc94b7ed3bcf37f5bfc8bc5d8bf8596954a60 (diff)
downloadpango-dd0245c7629630c52a33f301ce5ba687ec353cff.tar.gz
New public API:
2007-05-10 Behdad Esfahbod <behdad@gnome.org> * pango/Makefile.am: * pango/pango-ot.h: * pango/pango-ot-tag.c (pango_ot_tag_from_script), (pango_ot_tag_to_script), (lang_compare_first_component), (pango_ot_tag_from_language), (pango_ot_tag_to_language): New public API: PANGO_OT_DEFAULT_SCRIPT pango_ot_tag_from_script() pango_ot_tag_to_script() pango_ot_tag_from_language() pango_ot_tag_to_language() * tests/Makefile.am: * tests/test-ot-tags.c: Test case for new functions. * pango/pangoft2.def: * docs/pango-docs.sgml: * docs/pango-sections.txt: * docs/tmpl/main.sgml: * docs/tmpl/opentype.sgml: Updated. svn path=/trunk/; revision=2274
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 4 insertions, 17 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 549b89c4..d05667e3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,29 +44,16 @@ check_PROGRAMS = testboundaries testcolor testscript
if HAVE_CAIRO
check_PROGRAMS += testiter
endif
-
-gen_all_unicode_SOURCES = gen-all-unicode.c
-
-testboundaries_SOURCES = testboundaries.c
-
-testcolor_SOURCES = testcolor.c
-
-testiter_SOURCES = testiter.c
-
-testscript_SOURCES = testscript.c
-
-
-dump_boundaries_SOURCES = dump-boundaries.c
+if HAVE_FREETYPE
+check_PROGRAMS += test-ot-tags
+endif
gen_all_unicode_LDADD = $(GLIB_LIBS)
-
testboundaries_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
-
testcolor_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
-
testiter_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la ../pango/libpangocairo-$(PANGO_API_VERSION).la
-
testscript_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
+test_ot_tags_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la ../pango/libpangoft2-$(PANGO_API_VERSION).la
dump_boundaries_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la