summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-11-26 23:18:53 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-11-26 23:18:53 +0000
commite3f92b5972401c611f26f028804c4b7056f0be00 (patch)
tree6564f810c7235e71ffff0dd844961dc1438433e6 /tests/Makefile.am
parent1170903eb4010f837197c71d2817b9933b3f9ef4 (diff)
downloadpango-e3f92b5972401c611f26f028804c4b7056f0be00.tar.gz
Instead of including all-unicode.txt in the distribution, include a small
Mon Nov 26 18:17:00 2001 Owen Taylor <otaylor@redhat.com> * tests/Makefile.am tests/gen-all-unicode.c: Instead of including all-unicode.txt in the distribution, include a small program to generate it. * modules/hangul/hangul-x.c (render_syllable_with_ksc5601): When falling back to uncomposed Jamos, if we can't render a Jamo in any way, use the unknown glyph rather than nothing. * modules/hangul/hangul-x.c (hangul_engine_shape): Prevent overflows for invalid sequences which can be of arbitrary length. (#50086) * modules/arabic/arconv.c: New versions from Roozbeh Pournader. - Replacing the tables with automatically-generated ones - Using binary search instead of linear search for table lookup - Updating all the names with Unicode names (eg Nun -> Noon) - Fixed the Hamza mixup, using the Unicode rules - Updating missed cases (eg Superscript Alef was missing from arabic_isvowel) - Removing too-intelligent cases which made the code non-compliant (eg Alef with Hamza above+Kasra was changing to Alef with Hamza below) - Removing 'connecttoleft' from 'charstruct' (replacing it with a macro) - Indenting in the GNU style
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6bac8b1a..16bca8a8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,14 +4,18 @@ INCLUDES = -I$(top_srcdir) $(GLIB_CFLAGS)
TESTS=runtests.sh
-noinst_PROGRAMS = dump-boundaries
+noinst_PROGRAMS = gen-all-unicode dump-boundaries
check_PROGRAMS = testboundaries
+gen_all_unicode_SOURCES = gen-all-unicode.c
+
testboundaries_SOURCES = testboundaries.c
dump_boundaries_SOURCES = dump-boundaries.c
+gen_all_unicode_LDADD = $(GLIB_LIBS)
+
testboundaries_LDADD = ../pango/libpango.la
dump_boundaries_LDADD = ../pango/libpango.la
@@ -21,3 +25,7 @@ EXTRA_DIST = \
boundaries.utf8 \
runtests.sh
+all-unicode.txt: gen-all-unicode
+ ./gen-all-unicode > all-unicode.txt
+
+all-local: all-unicode.txt