summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2002-09-22 22:42:47 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2002-09-22 22:42:47 +0000
commit9534f3311d23e1ff48fd747b8568064946350e4d (patch)
tree5f4c1cfb04006ee7913ea4079de77b757b3875e1 /tests/Makefile.am
parentcd8f626345fdf182a927e36eb1af613590a9bdce (diff)
downloadpango-9534f3311d23e1ff48fd747b8568064946350e4d.tar.gz
Make color parsing more robust and correct. (#93804)
* pango/pango-color.c (pango_color_parse): Make color parsing more robust and correct. (#93804) * tests/testcolor.c: Tests for pango_color_parse. * tests/Makefile.am: Build testcolor. * tests/runtests.sh: Run testcolor.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4614025c..4571afb4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,18 +41,22 @@ TESTS=runtests.sh
noinst_PROGRAMS = gen-all-unicode dump-boundaries
-check_PROGRAMS = testboundaries $(CXX_TEST)
+check_PROGRAMS = testboundaries testcolor $(CXX_TEST)
gen_all_unicode_SOURCES = gen-all-unicode.c
testboundaries_SOURCES = testboundaries.c
+testcolor_SOURCES = testcolor.c
+
dump_boundaries_SOURCES = dump-boundaries.c
gen_all_unicode_LDADD = $(GLIB_LIBS)
testboundaries_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
+testcolor_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
+
dump_boundaries_LDADD = ../pango/libpango-$(PANGO_API_VERSION).la
if HAVE_CXX
@@ -71,3 +75,4 @@ all-unicode.txt: gen-all-unicode
./gen-all-unicode > all-unicode.txt
all-local: all-unicode.txt
+