summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@gnome.org>2006-01-23 16:27:21 +0000
committerBehdad Esfahbod <behdad@src.gnome.org>2006-01-23 16:27:21 +0000
commit8b728035f9cfe490ba109494eb8564d11552e374 (patch)
tree2cc04257fd0293666366d066fc5edac2fa382474 /tests/Makefile.am
parentce22d934fce30c8fce9b660221419f8a0055d565 (diff)
downloadpango-8b728035f9cfe490ba109494eb8564d11552e374.tar.gz
Make tests/examples do use generated pango.modules. (bug #328291)
2006-01-23 Behdad Esfahbod <behdad@gnome.org> Make tests/examples do use generated pango.modules. (bug #328291) * examples/pangorc, tests/pangorc: Removed. Moved to modules/. * examples/pangox.aliases: Removed. Moved to pango/. * examples/Makefile.am, tests/Makefile.am: Remove pango.modules creation stuff, copy pangorc from $(srcdir)/../modules/pangorc insteadd. * examples/renderdemo.c: Add --pangorc option, default to ./pangorc. Setenv PANGO_RC_FILE to whatever pangorc file decided. * tests/*.c: Setenv PANGO_RC_FILE to ./pangorc. * pango/pangox.aliases: Added. * pango/Makefile.am: Install pangox.aliases. * modules/pangorc: Added. * modules/Makefile.am: Create pango.modules. Added pangorc. * modules/.cvsignore, examples/.cvsignore, tests/.cvsignore: Updated.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am35
1 files changed, 12 insertions, 23 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e407b57f..d46b8469 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,13 @@
## Process this file with automake to create Makefile.in.
+EXTRA_DIST = \
+ all-unicode.txt \
+ boundaries.utf8 \
+ runtests.sh
+
+CLEANFILES = pangorc
+DISTCLEANFILES = all-unicode.txt runtests.log
+
INCLUDES = \
-DG_DISABLE_DEPRECATED \
-I$(top_srcdir) \
@@ -68,29 +76,10 @@ check_PROGRAMS += cxx-test
endif
cxx_test_SOURCES = cxx-test.C
-if CROSS_COMPILING
-all-local:
-else
-all-local: all-unicode.txt pango.modules
-endif
-
-pango.modules:
- if find ../modules -name '*.so' | grep 'so' > /dev/null ; then \
- echo "Writing a pango.modules file to use when running tests before installing Pango."; \
- (cd ../modules && \
- ../pango/pango-querymodules `find . -name '*.la' | grep -v \.libs` > ../tests/pango.modules ) ;\
- else \
- echo "No dynamic modules found; will use only static modules for uninstalled test programs."; \
- touch pango.modules; \
- fi
-
-EXTRA_DIST = \
- all-unicode.txt \
- boundaries.utf8 \
- runtests.sh
-
all-unicode.txt: gen-all-unicode
./gen-all-unicode > all-unicode.txt
-CLEANFILES = pango.modules
-DISTCLEANFILES = all-unicode.txt runtests.log
+pangorc: $(srcdir)/../modules/pangorc
+ cp $< $@
+
+$(noinst_PROGRAMS) $(check_PROGRAMS): pangorc