summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-08-28 01:19:29 -0400
committerMatthias Clasen <mclasen@redhat.com>2014-08-28 01:21:57 -0400
commit5d319c5989d599e9e867df76795eb81472b4db7a (patch)
treefaf441b11ea93bbb2a99ee8a40697feeedb2b311 /tests/Makefile.am
parent0c827ee95c4ff6564eefabb519d00bfcccd046fe (diff)
downloadpango-5d319c5989d599e9e867df76795eb81472b4db7a.tar.gz
Add tests for pango markup
This test is modeled after the GMarkup parser tests in GLib. Test file with a name ending in .markup can be dumped in tests/markups/, and tests/markup-parse can be used to generate the expected output files which should be in the same location and with the extension .markup replaced by .expected. The test is also used as an installed test.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 652c42f6..d8891836 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -43,7 +43,7 @@ TESTS_ENVIRONMENT = \
G_TEST_BUILDDIR=$(abs_builddir) \
PANGO_RC_FILE=./pangorc
-check_PROGRAMS = testboundaries testboundaries_ucd testcolor testscript
+check_PROGRAMS = testboundaries testboundaries_ucd testcolor testscript markup-parse
if HAVE_CAIRO
check_PROGRAMS += testiter test-pangocairo-threads
@@ -65,6 +65,7 @@ testscript_LDADD = $(TEST_PANGO_LIBS) $(GLIB_LIBS)
test_ot_tags_LDADD = $(TEST_PANGOFT2_LIBS) $(GLIB_LIBS)
test_pangocairo_threads_LDADD = $(TEST_PANGOCAIRO_LIBS) $(CAIRO_LIBS) $(GLIB_LIBS)
dump_boundaries_LDADD = $(TEST_PANGO_LIBS) $(GLIB_LIBS)
+markup_parse_LDADD = $(TEST_PANGOCAIRO_LIBS) $(GLIB_LIBS)
if HAVE_CXX
check_PROGRAMS += cxx-test
@@ -81,15 +82,26 @@ $(noinst_PROGRAMS) $(check_PROGRAMS): pangorc
noinst_PROGRAMS = $(check_PROGRAMS) gen-all-unicode dump-boundaries
+markup_tests = \
+ valid-1 valid-2 valid-3 valid-4 \
+ fail-1 \
+ $(NULL)
+
+all_markup_data = \
+ $(addprefix markups/,$(markup_tests:=.markup) $(markup_tests:=.expected))
+
+EXTRA_DIST += $(all_markup_data)
+
if BUILDOPT_INSTALL_TESTS
insttestdir=$(libexecdir)/installed-tests/$(PACKAGE)
insttest_PROGRAMS = $(check_PROGRAMS)
testdatadir = $(insttestdir)
-testdata_DATA = \
+nobase_testdata_DATA = \
all-unicode.txt \
boundaries.utf8 \
- GraphemeBreakTest.txt
+ GraphemeBreakTest.txt \
+ $(all_markup_data)
testmetadir = $(datadir)/installed-tests/$(PACKAGE)
testmeta_DATA = $(check_PROGRAMS:=.test)