summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-24 17:46:55 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-11-25 07:57:14 -0500
commitcddd173f713335318802a98f008d44b66ac4db46 (patch)
tree1d354ef8486e76d7359059bb87c9337af7189603 /tests/meson.build
parent5f539a0357ae3f5f1ebd4b97fb6844f70b48f30c (diff)
downloadpango-cddd173f713335318802a98f008d44b66ac4db46.tar.gz
Make test-layout use included fonts
Add Cantarell, DejaVu Sans and a subset of Noto Color Emoji to git, and make test-layout use just those fonts. This should help with keeping the ci from breaking due to different system fonts. Update tests.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 00741a14..ca53d103 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -44,18 +44,23 @@ if cairo_dep.found()
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
[ 'test-ellipsize', [ 'test-ellipsize.c' ], [ libpangocairo_dep ] ],
[ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-itemize', [ 'test-itemize.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-shape', [ 'test-shape.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
[ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
[ 'testserialize', [ 'testserialize.c' ], [ libpangocairo_dep ] ],
]
+ if build_pangoft2
+ tests += [
+ [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
+ [ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep, libpangoft2_dep ] ],
+ ]
+ endif
+
if host_system != 'darwin'
tests += [
[ 'testrandom', [ 'testrandom.c' ], [ libpangocairo_dep, gio_dep ] ],