summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-09-09 11:46:21 +0000
committerMatthias Clasen <mclasen@redhat.com>2020-09-09 11:46:21 +0000
commit51b2b2231b85af7fe4ade4ec98129b28182f7148 (patch)
treec07c8b83c955c620236682b6de1c8ba4b8ed4570 /tests/meson.build
parent25b057fa2ac6ea53b050e80dcc11cc9ed335b261 (diff)
parent8485a34055837fe2b8f58814c0bd3c25f97d610b (diff)
downloadpango-51b2b2231b85af7fe4ade4ec98129b28182f7148.tar.gz
Merge branch 'optional-dependencies' into 'master'
Make dependencies to libthai, cairo and xft optional. See merge request GNOME/pango!235
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 234fbf63..6e10e2b7 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -20,11 +20,7 @@ tests = [
[ 'testboundaries' ],
[ 'testboundaries_ucd' ],
[ 'testcolor' ],
- [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep ] ],
- [ 'testscript' ],
- [ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep ] ],
- [ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep ] ],
- [ 'test-break', [ 'test-break.c', 'test-common.c' ], [libpangocairo_dep ] ],
+ [ 'testscript' ]
]
if build_pangoft2
@@ -45,6 +41,10 @@ if cairo_dep.found()
[ 'test-shape', [ 'test-shape.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
+ [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
+ [ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
+ [ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
+ [ 'test-break', [ 'test-break.c', 'test-common.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ]
]
if pango_cairo_backends.contains('png')