summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2021-11-12 03:14:34 +0100
committerMatthias Clasen <mclasen@redhat.com>2021-11-15 16:20:57 -0500
commit3eae71709bb96ebc52b6f5ec31eca9a418bf07ca (patch)
tree00e2c61e68adecf71047a79b1f31499307d5f247 /tests/meson.build
parent9f82d3e4a6d4a628f306301fa8461810ba0446f6 (diff)
downloadpango-3eae71709bb96ebc52b6f5ec31eca9a418bf07ca.tar.gz
tests: Add spiced up wrapping tests
* Generate random string that looks like a sentence. * Measure the size at 100 random widths. * assert that for those widths, when sorted, the measured widths are increasing and the heights are decreasing. * Generate random string that looks like a sentence. * Generate a 2nd string adding hyphen + newline after every char of original string. * Assert that wrap-char wrap with width=0 is not larger than the width of the 2nd string The tests also generate random strings in LTR, RTL or both at the same time to spice the test up even more. It does that by picking random words out of hunspell directories, and if none are installed, it falls back to lorem ipsum.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 90bb94ba..81170c15 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -52,7 +52,8 @@ if cairo_dep.found()
[ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
[ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
- [ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ]
+ [ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
+ [ 'testrandom', [ 'testrandom.c' ], [ libpangocairo_dep, gio_dep ] ],
]
if pango_cairo_backends.contains('png')